DVR client can't find server

I'm attempting to connect a second Whole Home DVR client in my home on a CCGTV (wifi).

I'm getting an error when starting up the DVR app that the DVR is not quite set up yet, and to visit the URL to complete setup.

Heres some details:

-I had already been using this device successfully, and it had previously set up and running with no problems at all.

-I configured a new TS4k today and replaced the CCGTV in my main media room. The new TS4k works fine.. no problems. (The CCGTV is going to a bedroom now.) First time starting the app on the CCGTV in the other room after the TS4k, I got the error and couldn't connect.

-I have a Unifi network and strong wifi all over the house. I've attempted to start Channels on the CCGTV close to two different AP's, just to rule that out as a problem. I've also "forgotten" the network, and reconnected to it.

-I've rebooted the server and unchecked and re-checked bonjour. Bonjour says: Advertising dvr-server.local. via 1 network: []*

Raspberry Pi Operating system: 2021.0428.1701
Server version: 2021.06.11.0115
App version: 3.5.1.beta-v206092140

-I deleted and reinstalled the client app.

-No firewall on the Pi Server. Just the downloaded image.

-I tried to manually type the IP and port into the DVR search box, and the "DVR server was not found" error is returned.

-I have two phones with the android client, and they are working fine. And again, its working fine on the TS4k.

I'm getting green checkboxes on all the server troubleshooting areas.

I've gone ahead and submitted logs just in case thats necessary.

Thanks in advance for taking a look at this!

Could you submit diagnostics from the client app? It should be under the Help button.

Or access the logs directly via http://x:57000/log

Done, thanks.

Strange it's not able to connect to the IP of your DVR

06-10 23:40:54.709 9899 9899 V HTTP : Requesting GET
06-10 23:40:59.744 9899 9899 V DVRClient: Status error: Connect timeout has expired [url=, connect_timeout=5000 ms]

Especially strange because I've since set up yet another new TS4k today since my post, and it worked. Going to try a factory reset on the CCGTV.

Whatever it was, the device reset fixed it. Thanks for taking a look.