DVR Crash?

My wife said her Recordings were gone. Turns out her Apple TV was now pointing to my DVR. I tried to start it again within Synology Settings and would not restart. I restarted Synology and was able to start the DVR. But she was still pointing to my DVR. I tried to connect to her DVR in settings but it said it could not find it. Then I decided to STOP my DVR and then her Apple TV could find it. Again, it would be so nice to see both DVR's and just pick the one you want. Trying to enter DNS or IP's is a real pain especially when it will not connect.

Anyway, I found this in the LOG after restart:

2019/10/10 11:00:00 [DVR] Waiting 59m59.515237583s until next job 1570734000-132 Access Daily
2019/10/10 11:00:00 [DVR] Running commercial detection on file 3827 (TV/Josie Maran Argan Oil Cosmetics/Josie Maran Argan Oil Cosmetics 2011-01-02 2019-10-10-0900.mpg)
2019/10/10 11:00:00 [MTS] Statistics for "TV/Today With Hoda & Jenna/Today With Hoda & Jenna 2019-10-10-1000.mpg": skipped=0 unhandled_packets=0 discontinuity_detected=0 transport_errors=0 invalid_pts=0 invalid_dts=0 saw_pcr=true saw_pmt=true highest_pts=3612.833333
panic: runtime error: slice bounds out of range [5:3]

goroutine 1312714 [running]:*Sink).Close(0xc0001ca070)
/home/vagrant/gopath/pkg/mod/[email protected]/sink.go:314 +0x1fd*Job).Run(0xc0007e9800, 0xc000a04b50, 0x0, 0x0)
/home/vagrant/channels-server-x86_64/dvr/job.go:473 +0x1981*Recorder).RunRecorder.func3(0xc000a04a80, 0xc0007e9800)
/home/vagrant/channels-server-x86_64/dvr/recorder.go:450 +0x9c
created by*Recorder).RunRecorder
/home/vagrant/channels-server-x86_64/dvr/recorder.go:447 +0x528
[http @ 0x23e5240] URL read error: End of file
Error closing progress log, loss of information possible: End of file
2019/10/10 16:17:46 [SYS] Starting Channels DVR v2019.10.10.0342 (linux-x86_64 pid:18784) in /volume1/@appstore/ChannelsDVR/channels-dvr/data
2019/10/10 16:17:47 [HDR] Found 0 devices
2019/10/10 16:17:48 [SYS] Started HTTP Server
2019/10/10 16:17:58 [DVR] Recording engine started in /volume1/DS1019_DVR/Channels_Recordings

Thanks for letting us know. Looks like a bug in last night's pre-release build. Please update to the latest v2019.10.10.2324 for the crash fix.

I have not seen this again since upgrading to a new version.