DVR tab not showing up

I’ve got the DVR running on macOS, was able to record and playback a show (in the browser), but I don’t see anything in my Channels app on Apple TV. I’m updated to the latest 2.1.10. Any ideas? Is there a flag I need to enable or something?

Try quitting the app and restarting it (click TV/Home twice and swipe up).

Also check if correct ip is listed on Settings tab of web admin under Bonjour. You can uncheck and recheck the box while the app is running to signal a refresh as well.

Looks like the macOS server may have crashed. I saw this in the log (after I noticed that scheduled recordings weren’t being created either)

2017/01/21 13:31:00 [DVR] Processing file-1: TV/Match Game/2017-01-21-1300 Match Game 1962-12-31.mpg
2017/01/21 13:31:00 [DVR] Running commercial detection on file 1 (TV/Match Game/2017-01-21-1300 Match Game 1962-12-31.mpg)
2017/01/21 13:31:35 [DVR] Commercial detection finished with 4 markers.
2017/01/21 14:10:09 [HLS] Starting transcoder for file-1 at 0s
2017/01/21 14:10:14 [HLS] Stopping transcoder for file-1 after seek to 6m54s (out=1m1.194478s, finished=false)
2017/01/21 14:10:14 [HLS] error during ffmpeg progress: unexpected EOF
2017/01/21 14:10:14 [HLS] Starting transcoder for file-1 at 6m54s
2017/01/21 14:10:17 [HLS] Stopping transcoder session file-1
2017/01/21 14:10:17 [HLS] error during ffmpeg progress: unexpected EOF

Looks normal.

Ah, I figured the error (with nothing to follow) signified a problem. Rebooting Apple TV now.

If that logs looks normal, I’m not sure why the scheduled (series pass) recordings didn’t fire. Does “new” mean “first time to ever air” or “new to my collection”?

New means first airing. The DVR will never record something it has already recorded, so All means “any episode not recorded yet”

I have a similar issue, DVR tab not showing up on the Apple TV app, and have tried the steps on this page to no avail. Any other troubleshooting steps?

Try unchecking and rechecking the bonjour checkbox on the DVR web UI.

Also copy/paste what it says underneath the bonjour setting.

I have tried that several times to no avail.

This is what is listed under the Bonjour click-box, which seems correct to me.
Advertising dvr-alakazip-mini.local. via []

What is the IP of your AppleTV?

Excellent question.

What type of server are you using? Does it have a firewall. What has changed since you originally installed it?

Normally toggling the bonjour off-on and a swipe up to close the app and re-open fixes this.

You could also try the Bonjour browser app on iPhone or iPad to see if it shows the DVR

Update on this thread just to close the loop. My issue is now resolved, and likely the problem was not related to Channels.

After lots of troubleshooting it appeared my Synology 2600ac router was causing the problem. After enabling Apple Print Sharing and Mac File Server on my router the Bonjour broadcast worked as expected.

Hopefully this helps someone else, and thanks to everyone in this forum for assisting with the troubleshooting.