[ERR] Failed to start stream


#1

I’m looking for help regarding a recurring error that I get. Many of my recordings are missing large segments of video. When I look at the log I see many “[ERR] Failed to start stream on channel…” messages.

I use a HDHR Prime with a cable card. Thinking that my cable single to the tuner was weak I rewired my cable directly to the tuner to maximize the signal. I figured this was a hardware problem but my signal has been at 100% for weeks now and I still have this problem. Any ideas? Thanks for your time.

Some log examples:

2017/03/15 01:59:02 [DVR] Error running job 1489557600-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=71: EOF
2017/03/15 01:59:32 [DVR] Starting job 1489557600-ch211 Building Off the Grid: Coastal Maine on ch=[211]
2017/03/15 01:59:32 [DVR] Waiting 27.404787056s until next job 1489561200-ch211
2017/03/15 01:59:43 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=28: EOF
2017/03/15 01:59:43 [DVR] Error running job 1489557600-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=28: EOF
2017/03/15 02:00:00 [DVR] Deleting expired job 1489557600-ch211
2017/03/15 02:00:00 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:00:10 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3600: EOF
2017/03/15 02:00:10 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3600: EOF
2017/03/15 02:00:13 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:00:18 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3587: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:00:18 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3587: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:00:40 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:00:45 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3560: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:00:45 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3560: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:00:48 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:00:53 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3552: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:00:53 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3552: dial tcp 10.0.1.2:5004: i/o timeout
2017/03/15 02:01:15 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:01:27 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3525: EOF
2017/03/15 02:01:27 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3525: EOF
2017/03/15 02:01:57 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:02:08 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3483: EOF
2017/03/15 02:02:08 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3483: EOF
2017/03/15 02:02:38 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:02:49 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3442: EOF
2017/03/15 02:02:49 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3442: EOF
2017/03/15 02:03:19 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]
2017/03/15 02:03:32 [ERR] Failed to start stream on channel 211 via 13233E34: Get http://10.0.1.2:5004/auto/v211?duration=3401: EOF
2017/03/15 02:03:32 [DVR] Error running job 1489561200-ch211: could not start stream on channels=[211]: Get http://10.0.1.2:5004/auto/v211?duration=3401: EOF
2017/03/15 02:04:02 [DVR] Starting job 1489561200-ch211 Building off the Grid: Tiny House on a Lake on ch=[211]

#2

Strange, haven’t seen those EOF errors before.

Is 10.0.1.2 the correct IP for your PRIME?


#3

Also double check that your PRIME’s firmware is up to date.


#4

That is the correct IP address for the PRIME. I’m not sure if the firmware needs updating because I no longer see that option in the settings tab on the Channels app.

Thanks


#5

What kind of system is the DVR installed on?

Have you been able to make any recordings at all?


#6

It’s installed on 2008 mac pro, 2 x 3.2 GHz Quad-Core Intel Xeon with 8 GB ram. I would say 90% of the recordings work just fine, it just seems like only the most important recordings (sports) always have missing video. Most of the sports channels are mpeg2 streams, while nearly all my other channels are mpeg4 streams, though this problem happens with both types of streams.

The only other problem I have is inaccurate commercial detection but that really doesn’t concern me.

Thanks


#7

I can’t seem to find how to update my PRIME’s firmware. I’ve done this in the past but don’t see how to do it now. Can you offer any guidance? Thanks


#8

Also, I used this tuner for awhile with the PleX DVR and had no problems. Your software is so much better than the PleX DVR so I would really like to use it if I can get this problem figured out.


#9

The option in the app only shows up if you firmware is out of date. You can check http://10.0.1.2 and it will probably say 20161117 which is the latest.


#10

I would double check the ethernet cables… Are both the mac and the HDHR plugged into the same router/switch?

The errors indicate that the DVR is unable to connect to the HDHR’s IP for some reason.


#11

Ok thanks, I’ll look into that. I have had problems in the past with my ethernet connection. Thanks for your help…Jeff


#12

One last question: Is it possible to move my Channels DVR installation to another computer (mac mini) without losing all my settings and content?

Thanks for your time.


#13

There have been some reports that the hdhomerun branded ethernet cable that comes with the HDHR can be unreliable, so might be worth trying to swap out the cables.


#14

I am having a similar problem, so I am adding to this topic rather than adding a new one. Here is my machine:

OS
Apple MacBookPro8,2
Darwin
10.13.6 (kernel: 17.7.0)
CPU
4 cores / Intel(R) Core(TM) i7-2635QM CPU @ 2.00GHz
load averages: 1.46 1.95 3.35
RAM
16.00 GB
77.4% free

I have been using a windows PC for 2 years, and the DVR has been working great. Recently, the aging Windows PC was shutting down without notice, so I ended up moving the DVR to a 2011 MacBook Pro on 6/1/2019. The first recording was successful, but the past couple days I am getting incomplete recordings. All cables & switches are the same, so I am perplexed why dropped connections would be occurring on the new machine. I install the auto-wake, and when that did not seem to improve things, I installed a Jolt/Caffiene app from the Mac App Store that is supposed to force the machine from sleeping. It appears to be disconnecting roughly every 15 minutes, and then reconnecting, causing outages in the recordings. Here is a recent example from the log:

2019/06/05 17:10:37 [DVR] Commercial detection finished with 10 markers.
2019/06/05 17:21:19 [DVR] Waiting 2h38m10.612785s until next job 1559789970-16 The Amazing Race
2019/06/05 17:22:40 [DVR] Starting job 1559779200-ch5.1 KING 5 News at 5 on ch=[5.1]
2019/06/05 17:22:40 [DVR] Waiting 2h36m49.483998s until next job 1559789970-16 The Amazing Race
2019/06/05 17:22:40 [TNR] Opened connection to 1047DDB6 for ch5.1
2019/06/05 17:22:40 [DVR] Recording for job 1559779200-ch5.1 from 1047DDB6 ch5.1 into "TV/KING 5 News at 5/KING 5 News at 5 2016-02-22 2019-06-05-1722.mpg" for 37m49.483893s
2019/06/05 17:22:40 [DVR] Refreshing metadata for KING 5 News at 5 (12598253)
2019/06/05 17:47:49 [DVR] Cancelling stream 1047DDB6 ch5.1 after 6s read timeout
2019/06/05 17:47:49 [TNR] Closed connection to 1047DDB6 for ch5.1
2019/06/05 17:47:49 [DVR] Job 1559779200-ch5.1 KING 5 News at 5 ended prematurely: 12m40.519013s
2019/06/05 17:47:49 [DVR] Starting job 1559779200-ch5.1 KING 5 News at 5 on ch=[5.1]
2019/06/05 17:47:49 [DVR] Waiting 2h11m40.512494s until next job 1559789970-16 The Amazing Race
2019/06/05 17:47:51 [ERR] Failed to start stream on channel 5.1 via 1047DDB6: Get http://10.0.1.3:5004/auto/v5.1?: dial tcp 10.0.1.3:5004: i/o timeout
2019/06/05 17:47:53 [ERR] Failed to start stream on channel 5.1 via 10481BAC: Get http://10.0.1.2:5004/auto/v5.1?: dial tcp 10.0.1.2:5004: i/o timeout
2019/06/05 17:47:53 [DVR] Error running job 1559779200-ch5.1 KING 5 News at 5: could not start stream on channels=[5.1]: Get http://10.0.1.2:5004/auto/v5.1?: dial tcp 10.0.1.2:5004: i/o timeout
2019/06/05 17:48:23 [DVR] Starting job 1559779200-ch5.1 KING 5 News at 5 on ch=[5.1]
2019/06/05 17:48:23 [DVR] Waiting 2h11m6.092895s until next job 1559789970-16 The Amazing Race
2019/06/05 17:48:24 [TNR] Opened connection to 1047DDB6 for ch5.1
2019/06/05 17:48:24 [DVR] Recording for job 1559779200-ch5.1 from 1047DDB6 ch5.1 into "TV/KING 5 News at 5/KING 5 News at 5 2016-02-22 2019-06-05-1722.mpg" for 12m6.092802s
2019/06/05 18:00:30 [TNR] Closed connection to 1047DDB6 for ch5.1
2019/06/05 18:00:30 [DVR] Finished job 1559779200-ch5.1 KING 5 News at 5
2019/06/05 18:00:30 [DVR] Waiting 1h58m59.633061s until next job 1559789970-16 The Amazing Race
2019/06/05 18:00:30 [DVR] Processing file-1059: TV/KING 5 News at 5/KING 5 News at 5 2016-02-22 2019-06-05-1722.mpg
2019/06/05 18:00:30 [DVR] Running commercial detection on file 1059 (TV/KING 5 News at 5/KING 5 News at 5 2016-02-22 2019-06-05-1722.mpg)
2019/06/05 18:03:12 [DVR] Commercial detection finished with 8 markers.

If you have any suggestions it would be greatly appreciated.

Neglected to mentioned I have 2 Connect Duos.


#15

Pretty strange. Perhaps there is an IP conflict and two devices are competing for the same IP?


#16

Thanks for your suggestion, I assigned a static IP address at the end of the range, and attempted to record again. The results were the same. The recording went for 25 minutes, then the connection dropped. I realize the 2011 MBPro is 8 years old at this point, but hoping to get continued use out of it. I feel this is sleep related. I am trying to run the DVR with the clamshell closed to save the monitor. Even though I have auto-wake enabled, and the jolt software on, the light on the front of the MBPro seems to go from steady to a slow blink after time. I have the Energy Saver settings on the the battery as well as the Power Adapter to never sleep, so I am not sure what else to try. You can probably tell from prior post, but this is using High Sierra MacOS. Any additional suggestions?

Thanks again!

LOG

2019/06/06 07:25:28 [TNR] Opened connection to 1047DDB6 for ch5.1
2019/06/06 07:25:28 [DVR] Recording for job 1559829600-ch5.1 from 1047DDB6 ch5.1 into "TV/Today/Today 2019-06-06 2019-06-06-0725.mpg" for 1h35m1.508072s
2019/06/06 07:50:04 [DVR] Cancelling stream 1047DDB6 ch5.1 after 6s read timeout
2019/06/06 07:50:07 [TNR] Closed connection to 1047DDB6 for ch5.1
2019/06/06 07:50:07 [DVR] Job 1559829600-ch5.1 Today ended prematurely: 1h10m22.819596s
2019/06/06 07:50:07 [DVR] Starting job 1559829600-ch5.1 Today on ch=[5.1]
2019/06/06 07:50:07 [DVR] Waiting 11h39m22.812486s until next job 1559874570-45 Jeopardy!
2019/06/06 07:50:09 [ERR] Failed to start stream on channel 5.1 via 1047DDB6: Get http://10.0.1.3:5004/auto/v5.1?: dial tcp 10.0.1.3:5004: i/o timeout
2019/06/06 07:50:11 [ERR] Failed to start stream on channel 5.1 via 10481BAC: Get http://10.0.1.2:5004/auto/v5.1?: dial tcp 10.0.1.2:5004: i/o timeout
2019/06/06 07:50:11 [DVR] Error running job 1559829600-ch5.1 Today: could not start stream on channels=[5.1]: Get http://10.0.1.2:5004/auto/v5.1?: dial tcp 10.0.1.2:5004: i/o timeout
2019/06/06 07:50:41 [DVR] Starting job 1559829600-ch5.1 Today on ch=[5.1]
2019/06/06 07:50:41 [DVR] Waiting 11h38m48.019152s until next job 1559874570-45 Jeopardy!
2019/06/06 07:50:42 [TNR] Opened connection to 1047DDB6 for ch5.1
2019/06/06 07:50:42 [DVR] Recording for job 1559829600-ch5.1 from 1047DDB6 ch5.1 into "TV/Today/Today 2019-06-06 2019-06-06-0725.mpg" for 1h9m48.019078s


#17

I found the follow note on an app called Amphetamine. I find this a little strange. Does anyone know of a workaround? I would prefer not to hook up a monitor, keyboard and mouse just so the MacBook Pro can record with the lid closed.
54%20AM


#18

Looks like that may be the only way: https://support.apple.com/en-us/HT201834


#19

Thanks, this is a still surprising to me. Not necessarily for Channels, but I think Apple would have a use case to allow people to close their laptop and use it as an iTunes server or similar functions, especially with all the connected devices they offer in their ecosystem.

I am running the DVR with the lid open, and this functions. Thanks for reviewing.