Error message: “Connected to but SSL certificate is invalid”

Connected to but SSL certificate is invalid.

I have updated your account domain. Try turning remote access off and back on (at home or via vpn)

1 Like

I am having the exact same issue and error message under my support tab when troubleshooting. I can access it remotely via my Safari web browser, but it fails every time when trying to access my server remotely on my AppleTV 4K.

Is there something you need to do on your end to get this working? I already tried turning remote access off and back on and verified my remote router settings numerous times.

Thanks and Happy New Year!

1 Like

I've updated your account. Turn remote access off and back on, then wait about five minutes.

1 Like

You my friend.....are INCREDIBLE!!! :innocent:

1 Like

It worked! :slight_smile:

Out of curiosity, what is it you have to do in our accounts to fix this?

The domain assigned to you gets updated from to

The latter uses a different DNS provider which is more reliable.

This issue only affects long-time customers who signed up when we were still using the old provider and setup remote access. New users already use the new provider. You can tell if this issue is affecting you by seeing if the url for changes to xxx or yyy.u


Can you update my DNS provider as well? I am receiving the same error message. I was a previous subscriber, then went dormant, and just recently re-subscribed to Channels DVR. The error I am receiving is "Connected to but SSL certificate is invalid", and it seems like the DNS provider update will solve the issue. Thanks so much!


I'm also having this issue. Could you update mine too please? Thank you

You are already on the new provider. What error message are you seeing?

I am having the same issue too. I can access remotely on the website but not on the apps. I get an invalid SSL certificate. I have been using channels for long time. Could you update my account?


Hi, I'm getting the same error. "Connected to but SSL certificate is invalid." Can you help me please?

God bless,

Please update your DVR by clicking the dropdown icon next to Check for Update and select Prerelease. Wait about five minutes and it should be fixed.

That worked. Thanks and God bless.

I am getting 'Connected to but SSL certificate is invalid' when I run the troubleshooter.

I cannot connect to the app remotely.

Toggle remote access and try again now

It works now! Thank you!

I'm having this same issue, can you please update my DNS provider?

Remote Access
Connected to but SSL certificate is invalid.