Failed disk access


My raspberry pi installation of Channels DVR failed to record several OTA shows the other night because the disk was read-only. The server was online that night, but sometimes the server becomes completely inaccessible, seemingly when I move the pi and disk around on my desk. Could this be happening because the OS is running on the USB drive? Is that setup unstable?

Can you click Support > Submit Diagnostics on the DVR web UI?

What kind of USB drive are you using?

Submitted the diagnostics.

The drive is a WD 1TB Elements Portable External Hard Drive HDD, USB 3.0

Thanks

Did the Pi suddenly lose power at some point?

When it isn’t functioning right I do a power cycle. But not otherwise, to my knowledge.

Are you using the power supply that came with it ? They are sensitive to the amount of electrical current input. Frequent restarting is not ideal for a server

Meaning, mostly, that they need slightly more power (amps) than a typical usb charger brick, and it is very much recommended to the OEM cord, or one known and certified for the Pi such as the one that comes in the CannaKit's. be warry of the ultra cheap China random ones, that can come with nice cases one can buy on Amazon or Ebay, for like $10. They may not be able to put out the max power requirements and will not work if you set any form of over clock etc, on the Pi.
That being said, I have used a few generic Pi power adapters, with no issues.

Also, no, the Pi, at least the Pi4 8GB that i have that is my "testing" "mess around with" unit and it seems hundreds of power cycles every day as i swap sd cards or mess up something in the os and it freezes. etc. Maybe it is bad for the overall life of the board, but I don't see how it would be any different than any other small computer or electronic device alike to it.

I had the same ‘read-only’ disk permissions issues with my RPi 4 USB boot installation. I got a powered 4-port USB 3 hub, plugged my WD My Passport drive into the hub, and I have not had any disk permissions errors since.

Were you a frequent user of remote transcoding?

No, not really. If I know that I have a recording coming up I might check to see if the server is up, but that’s about it.

Things have been working continuously without error for a few days now.

Regarding power: the cord is the one included in the suggested recommendations. I don’t power cycle often, only when the server is unreachable and I need to reboot the pi.

Maybe the gremlins have disappeared now...

I'd suggest updating to the latest OS beta by click-and-hold on the update button. That has better diagnostics and an updated disk driver to help prevent these problems.

Oh ok great. Thanks.

Do you use the samba feature?

Good question. I tried once so I could move recordings over from an old disk, but it was going super slow do I quit and turned it off.

For what it’s worth: I tried replacing my Cannakit power cord with a laptop cord and haven’t had a single issue since. No “server unavailable” messages, no missed recordings, no errors. Time will tell, and I’ll replace the laptop cord with an official rpi cord, but it seems fixed. I wonder if the non-compliant usb-c connection that is inherent to the rpi 4 is playing a roll.

1 Like