Favourites / Channel list not hiding when selecting channel

Since the last couple of updates I’ve had the issue where a channel cannot be shown – selecting a channel via the guide or on now screens will switch channel (I can hear audio change) but the actual selection screen doesn’t disappear. The guide and/or on now screens remain on screen. Force quitting the app doesn’t help and neither did a restart of the Apple TV. Eventually a combination of a lot of force quitting / restarting after about 10 minutes it eventually started working for me. Has happened about 3 times now over the past 10 days or so. Has been rock solid for years prior...

Also tried changing channels via iOS app to the AppleTV with same issue.

What version number is shown in the app?


Interesting. Could you make a video showing the problem and email it to [email protected]

Will do next time it happens. The click seems to work (click action) and the channel changes but the guide screen remains.

OK, just happened again - have emailed video file showing the issue. This time a force quit fixed it thankfully.

The next time this happens could you Submit Diagnostic Logs from the app before force quitting it?

How often does this happen? I’m trying to recreate what you’re seeing.

I had the same issue just now. First time force quit did not fix it. Seems a second time did it though.

Will do. It only happened once about 2 weeks ago and has happened twice in the last couple of days.

Do you recall if you had opened the app by playing something via the Top Shelf in the tvOS home screen?

I may have in the past, but not usually... in the video I sent showing the issue, that session was launched via the app icon directly.

I noticed the same issue today. I am able to reproduce it reliably.

Starting from the app being force closed, choose a show from the top shelf, the app opens and starts the show (I can hear the audio), but the guide (or whatever top menu was open last) stays visible on the screen.

Force close and open from the app icon, choose a show from the guide and it works as expected. When you exit to home screen, the top shelf now works as expected.

Edit: version 3.2.40

This issue has been resolved for a while on the 4.0 beta. You can grab it from TestFlight. If you're not on the beta, you can join here: https://getchannels.com/beta/

I have the same problem and at least this morning I was able to reproduce the problem by starting a channel from top shelf.

Any schedule for a fix for us that are not plus subscribers?

We just submitted a new version to app review. It should be available sometime tomorrow.

1 Like

same happening here sound but no picture