Fox @ 4k HDR

@tmm1 I just tried your new build, still get EOF.

2023/02/12 19:44:00.030854 [ERR] Error during stream TVE-Cox ch6002 WVBT: signal: segmentation fault (core dumped)
2023/02/12 19:44:00.030871 [TNR] Closed connection to TVE-Cox for ch6002 WVBT
1 Like

I’m calling it now: @tmm1 for MVP :football: :trophy:


Sorry no easy fix for 4K feed on Linux DVRs

1 Like

I remotely updated the server on Windows and it seems to be working with the 4k box checked! Not sure how to test to see if it is recording in 4k from my tablet away from home. Great to see that it is actually recording regardless.
I was able to get the first 90 minutes of the game recorded in 720p. It looks like it is working in 4k from the two minute warning onwards.

Great Job Developers working great on my Windows Server.

I would have loved to try it too but I lost my Fox channel after one of the updates earlier today. It is no longer in my DirecTV lineup. Once my DVR is idle, I will upgrade to the latest and then try to get it back by unchecking the local channels option and enable it again.

Anyway, it seems that you got Fox TVE 4K working in Channels. Fantastic! :clap:

1 Like

Depends on the source too. A football game vs a concert vs a movie ect. Upmixing two channel for crowd noise isn't that much of a trade off. I would choose the HDR for football for sure.

1 Like

I take it that this "hack" for the Super Bowl, won't carry over to any other Fox "4K" production? It will take the Docker EPlusTV method moving forward? Is that due to the Super Bowl being open to everyone with no need for credentials?

1 Like

Free access vs 4K feeds are separate concerns. Work to integrate 4K support is ongoing.


Does this address the Linux issue for the future or was that not an fmp4 problem?


There's a 4K game on FS1 tonight.

14-Feb 9:00 PM EST NCAABB St. John's @ DePaul FS1 4K

You should be able to add 5 minute prepadding and still record the 4K stream.

1 Like

I initially got very excited at this but have just read there are issues with Linux?

I'm running Channels server from a Pi4B (watching Apple TV4k, Firetv4K, Android TV). Is this currently an issue?

The Linux issue was just for the mad fix to get the superbowl in 4K. FS1 4k worked prior with Linux no problems. Can’t really speak of the pi4 but should work fine.

1 Like

Brilliant. I'll give it a try tonight. I'm going to expect NBC 4k is off limits as I'm almost certain they do not stream their 4k sports content on their website but is BTN currently possible?

1 Like

Don’t forget to check this box at the bottom of settings page

1 Like

That's exactly what I had forgotten to do!

Thanks all. I'm only kicking myself that I somehow missed this for the past few weeks.

Don't worry. That seeing has only been there for 3-4 days.

This is streaming in 4K for me right now, cool! I was experimenting with this feature and noticed too that it streams in 4K even when the experimental "Stream 4K and HDR via TV Everywhere" checkbox is unchecked. At least it did for me after I unchecked it, force quit the Channels client, and re-launched it to try again. Checking and unchecking that box seems to have no effect. This game is streaming in 4K on my AppleTV client, regardless.

1 Like

Tried to start recording on time and it’s still grabbing the 720 stream. Stopped and deleted recording, restarted recording 8min in and it grabs the 4k stream.

Logs have been submitted as 81bc5332-f392-42f9-a1f7-8856235933ec