Frame dropping

I’ve been using the iOS betas for about a week and a half now and as far as picture goes everything seemed fine. Now, I’ve mainly been watching TV shows with minimal movement, or at least movement that was not as quick as sports. However tonight I decided to watch some of the Red Sox game through the latest beta on my iPhone to see how the experience was. I immediately noticed what I can only describe as dropped frames, which causes the picture to look like it’s been frozen ever so briefly. It happens every few seconds but is very noticeable in 60fps sports. The channel I was watching on is NESN which is a 1080i signal, so I thought perhaps it was something to do with using the blend deinterlacer, so I changed it to linear. Same issue. I then remembered that ESPN (720p) is also carrying the game tonight so I tried that, thinking maybe it’s a deinterlacing issue in general, but it happens there too. The feels like it happens not quite as frequently on the 720p channel vs. the 1080i channel, but it’s close.

I went over to both my Apple TVs and turned the game on them both through the current release of the Channels tvOS app and it was perfect. No frame skipping. Then just to cover another base (no pun intended) I power cycled my HDHR Prime. No difference. I then stood right next to my wireless access point (Ubiquiti AC-Lite) and still had the issue. I rebooted the access point and router but still have the issue. For the record I’m connecting to my access point via the 5 GHz AC network. My Apple TVs are connected to my network via Ethernet, but just for testing purposes I put them on the AC wireless network and there is no frame dropping like I see with the iOS app.

Having said all that, I haven’t seen any other reports of this, and so I’m wondering if this is something that anyone else is seeing (again, look at a sports broadcast)? Devs, is this any kind of issue you’re aware of?

If needed I should be able to capture this happening using my lightning to HDMI adapter but will need to see where I stashed it tomorrow.

Edit: I should add that I’m using an iPhone 6s running iOS 9.3.3. An additional troubleshooting step was power cycling the phone.

Thanks for the detailed report.

It’s possible the deinterlacers aren’t performing well on the mobile devices… I can add a “None” option for the next beta, if that fixes the framedropping then we’ll know it’s the issue. Did you notice any difference at all between Linear and Blend? Blend should be less CPU intensive.

Have you noticed issues on any other channels?

You’re welcome.

For testing I watched various different sports channels, broadcasting in both 1080i and 720p with both blend and linear deinterlacing, and it actually seems like blend shows the issue a bit more frequently than linear, though it’s so close that it may be a wash. Throwing in the ‘none’ option for interlacing in the next beta is a good idea.

I really wish I could find my iPhone HDMI adapter so I could direct capture this and send it to you, but I can’t find it for the life of me. I’ll keep looking for it, and if I end up being able to capture this I’ll let you know.

I installed the updated beta and disabled interlacing. I then put on the same channels (well, the ones that had fast motion sports replay programming on this morning, since no love sports are on at the moment) and the frame dropping continues.

Well, it looks like the most recent beta fixed the issue with the frame dropping. I know the change log says improved video decoding on A7 devices and I’m not sure if that’s related, but this beta fixed the issue with my A9 powered iPhone 6s.

Maybe u spoke too soon. Tuning in again and am seeing it again.

I’m going to experiment by setting up a different wireless access point and router to see if that makes any difference with regard to this. The fact that no one else has come on here and said they’re also seeing it makes me think the issue may be more likely on my end one way or another.

The latest updated has made a huge difference for me. I thought I had a wifi issue. Prior to the update, I couldn’t watch anything due to the dropped frame issue. Now, there is an occasional dropped frame on my iPad Air 2. It only occurs when my hand blocks a corner of my iPad, otherwise it’s working well.

Latest beta changes only affected older A7 devices, so does seem like something else is going on for you. Let us know how swapping out the router works out.

I brought home one of the spare Cisco AC routers from the office today and connected it at home. I completely powered off my regular router and access point and connected just the cable modem and HDHR Prime to the new router. I experienced the same frame dropping issue.

Since that made no difference I connected my old router and access point. After that I decided to try a simple thing I hadn’t though to even try, which was just to uninstall the app and re-install it. I figured it was worth a shot, but it didn’t make a difference.

The next thing I’m going to try is bringing home a spare iPad or iPhone from the office tomorrow and install the beta on that to see if the same issue continues for me even on a different device. I’ll post an update once I’ve tried that.


If you have a mac, you can use a lightning cable and Quicktime to record audio/video from the device:

Unfortunately I don’t. However if I also have the issue with another device I’m going to see if I can capture the phenomenal the old school way using a video camera. Better than nothing, if it ends up being able to show it.

I tested Channels mini out on an iPad Air 2 today and got the same issue with the frame dropping/skipping as I’m experiencing on my iPhone 6s. Since I had the two devices available, I used my iPhone’s camera to record a clip at 60fps which illustrates the issue right in the middle of a pitch during a baseball game. It’s probably the most obvious piece of footage that illustrates the issue. The very short clip can be downloaded from this link:

I don’t have permissions to download that file.

Oops, I accidentally stripped the auth key out of the URL. This one should work:

Got it, I was able to watch the video. Very strange indeed.

Have you tried the SD version of the same channel, to see if that’s any better?

Good question. I don’t think I did that, as I have all of the SD channels hidden in my HDHR. I will try that tonight and let you know.

Just checked out part of a Mets game on the SD channel and it’s not happening there. I flipped it over to the HD channel and was seeing it.