Getting my.channelsdvr.net to work


#1

Hello:

I’ve looked through several of the posts related to this topic to see what I’m missing in regards to getting the my.channelsdvr.net link to work with my DVR setup. I’ve opened port 8089 to my NAS, and using the external IP the DVR is accessible outside of my network. I’m also running Plex on my server, which works fine for remote connections through their website/apps. On the Remote DVR section of the DVR control planet port forwarding is set to automatic, and it says it is listening on xx.xx.xx.xx:8089, but I don’t know how to make the my.channelsdvr.net URL work. Clicking on it says “Safari cannot open the page because the server cannot be found”. This also means that the server is not reachable via the iOS apps. Any help is greatly appreciated.


#2

When you say "I've opened port 8089 to my NAS", can you describe the steps you took?

You need to create a port forward rule in your router that forwards the internal port 8089 associated with the "xx.xx.xx.xx" ip of of your server to the 8089 external port. Should look something like this...

Port Forward:
Name: Channels (you can name it whatever you want)
Forward Port: 8089 To: 8089
IP: 192.168.1.123 (replace this with the Lan IP of your Channels DVR)


#3

So within the web interface for my router I forwarded Port 8089 to the internal (static) IP of my server. I did the same for the port Plex uses. I can access the server using the external IP address, but the non-IP web address does not function.


#4

Sounds like a hairpin NAT issue. Most consumer routers do not handle this well. The reason this works with Plex is that their clients are all being funneled through their servers. Channels does not seem to constantly funneling all requests through their servers, which is why you see this situation.

You can either run your own DNS to mirror what is going on outside your network on the inside, or just use 2 separate addresses when accessing your server: one when on the LAN and another when remote.

(Or, upgrade your router to one that does hairpin NAT translation. Some routers also call this a loopback NAT.)


#5

Use portchecker.co to verify 8089 is open, then try my.channelsdvr.net on LTE on your phone.


#6

I run Channels on my Synology DS1019 and access Channels DVR Remotely without any problems. I also run PLEX on the same DS1019 without problems.

OP says he uses "automatic on the DVR" which I believe uses uPNP which maybe he should change to Manual since he is manually using PORT FORWARDING which is what uPNP sets up. I have disabled nPNP in my Router because I do not like this happening. I always use Manual Port Forwarding. Not saying this is a problem but kind of does not make sense to do both.


#7

I have checked to make sure 8089 is open (it is), and have tried the web link through LTE on my phone (no joy). I have also tried toggling the Remote DVR setting on the DVR settings page between “on” and “off” as well as “manual” and “automatic”; neither has helped. I’ll have to investigate further the hairpin NAT issue.