Guide logos from m3u

Have some custom channels that are using gracenote data that don’t have a logo so I have linked to some logos via the m3u that are stored locally.

They seem to load fine when I use my iPhone remotely but when I use the guide on Apple TV locally most of them can’t be viewed, though 1 or 2 still can?

Is this maybe an incompatibility issue with tvos and the images I’ve used or is this to do with the latest beta build changing some image stuff? (Wouldn’t have thought so though as like I said, some still seem to load in for some reason)

Have tried to refresh logos on the dvr settings and refresh source on the client.


I think it’s new beta related. Do the images load in the stable non-beta app?

Please provide the URL to the image that will not load. This would be the most useful information while troubleshooting a URL that does not load.

Looks like it was an incompatible file
Weird that it worked for iOS but not for tvOS

Downloaded some files that the website said were pngs but were named webp. Saved them as a .png and opened as a .png would on windows.

Strange they worked for iOS tho

Sorry I should’ve looked into it before I posted.

Classic garbage in, garbage out. Thanks for reporting back!