Having Issues Getting HDHR and Channels to Work on Nvidia Shield

As far as I can tell, I have everything set up. I have the Guide Data up on the Channels app on the Shield, but whenever I try to tune to a channel I get the following message:

Connection Lost
Unable to tune or get signal lock (no_signal_lock)

Any assistance would be appreciated!

Can you tune and watch on the native hdhr app?


"No devices found
Unable to find HDHomeRun tuner on local network

Please check that your HDHomeRun and this device are both connected to your local network"

I'm not sure how to connect the HDHR to the local network other than connecting it to the Shield via ethernet.

You plug the hdhr into your router via Ethernet cable. Your shield should also be plugged into your router via Ethernet(preferred) or WiFi.

Plugging the HDHR into the router isn't an option. When it was set up with the PC I just connected the two devices to each other through ethernet and that worked. That doesn't work with the Shield?

Im afraid you will need to make it an option. You cant connect the hdhr directly to anything. Not sure how you got to work before as you need dhcp which you wont have connecting it directly to your pc.

You could use moca to get ethernet to your hdhr. As long as there is coax that runs near your router it could be an option. One moca device would connect to your router. Connect a switch the other moca device and then connect your hdhr and sheild to it.

I have T-Mobile 5G Home Internet. There's one location in the apartment where I get a signal, and it's in a completely different room from the antenna coax. Before I got TMO I had a Nest mesh system. I still have all the devices, but didn't need them because the wifi from the TMO gateway is strong enough to feed the whole house. I could try to get the mesh up and running again.

I don't know how hooking the Shield and mini PC together worked, but it did. The only reason I'm switching to the Shield is because the PC was unreliable.

You need to set your mesh network back up. Place the router next to the T-Mobile gateway and plug the router's WAN port into one of the gateway's LAN ports. Then locate the mesh nodes as needed where they get a decent signal.

A reliable and fast network is a must!

Unfortunately in my nearly sixty years I've never lived anywhere that had coax running from room to room. I got the mesh set up and plugged both the Shield and HDHR into an ethernet splitter. The Shield says that it's connected and there's an IP address assigned, but none of the apps recognize that it's online.

I have multiple issues that need to be addressed before I can make this work. I have many calls with tech support in my immediate future.

  • edit * It appears the splitter is part of the problem: one device can connect at a time. I need to read product descriptions more closely.

I had a 16 port ethernet hub that I rescued from the trash bin at work a few years ago. It's been tranferred from the trunk of one car to the next. It seems to be solving the problem. Everything is working for the moment.

Thanks for the help!