Help, stuck in "On Now" menu

I was browsing the On Now menu in the latest beta on my Apple tv 4k, all I see is:
No Channels
Scan for channels by picking your HDHomerun in the Settings tab.
But I can't. I can only click left or right to the other On Now tabs such as HD and Favorites, but I can't leave this option. If I click Menu, it opens the left side bar but I can't click down to try to select Guide or Library, etc. It simply puts me back into the On Now tabs. I tried force quitting the app by double pressing the home key and swiping up, but once I relaunch the app, it starts me again in the same place. I also tried restarting the appletv, but it still starts me in the On Now tab. I'm simply trapped there.
Oddly, the behavior has spread to the other app I have installed from the App Store as well.
Please help!

Check for firmware updates and channel scan via ?

1 Like

I don't have an hdhomerun installed. I'm using a Shield as my server and only using TVE sources and Locast subscription. It's really weird that it's just stuck in this menu. The Shield and each of my Firesticks are all performing correctly

Try using the API to switch to another tab maybe?

Or clear the app cache?

1 Like

Couldn't figure out how to clear the cache, but after uninstalling and reinstalling, the app is back up and running again