iOS DVR Search and Special Characters


#1

I was trying to search for Won't You Be My Neighbor in the DVR function of the iOS app and noticed that it seems to not understand how to include the ' in the search terms.

I was able to find it by searching on the word neighbor as well as won (but Won't You Be My Neighbor was far down in the list).

I was unable to get any results with

won't
wont
won't

Would it be possible to include characters used in titles or potentially strip out special characters in the show titles?

Or am I missing something?

I am using the remote DVR function (i.e. my iOS app / phone are on my work address connected to my DVR at home).

I am running Channels 2.2.12 on IOS 12.1.2 (16C101)


#2

Does it work on the DVR web UI?


#3

I just checked and searching for "won't" returned results including "Won't You Be My Neighbor?"

What version are you having problems with. I'm using Channels 2.2.12 with iOS 12.1.1 on an iPad Pro.


#4

Yes - just connected to the house and the DVR Web UI does find it -

http://channels-dvr:8089/admin/search?q=won't


#5

I am running 2.2.12 with iOS 12.1.2 on an iPhone 7+

It doesn't work for me with "won't" or won't

Charley


#6

I'm running Channels 2.1.12 on iOS 2.1.2 on an iPhone 6S. Entering "won't you be my neighbor" into search finds a 2018 documentary about Fred Rogers and "The Daniel Tiger Movie: Won't You Be Our Neighbour?"


#7

Interesting - that doesn't work for me -

Screenshots attached -

searching on phrase (with or without quotes)

Searching on word Neighbor

image


#8

I should probably add that my DVR is running on an Ubuntu linux box (18.04 LTS) - running dvr version 2018.11.20.2224

Charley


#9

Your phone is replacing ' with a smart quote which is not the same character. Same thing with the double quotes. You can turn off this behavior in the settings. It's possible there's a way for us to do the same on that text field..


#10

Fixed for next beta.


#11

Wonderful - I confirmed that when I disabled Smart Punctuation via

Settings -> General  -> Keyboard -> Enable/Disable Smart Punctuation

Searching for something with a ' then works -

Charley