Ip camera into Channels

I am new to Channels and would like to input a IP camera.
I have a LTS CMIP8212B camera and have found the RTSP stream as follows.
I have created a custom channel as follows

When I use the RTSP steam in VLC it asks me for a username and password.
When I play it in channels I get connection lost (-17)

Anybody have any suggestions?
Thank you

Try changing your URL to include the user/pass:

rtsp://user:[email protected]:554/Streaming/Channels/1?transportmode=unicast&profile=Profile_1

thank you for responding. Inputting the user/pass did not work.

Let me clarify,
I input the user/pass and it worked in VLC without having to manually input the user/pass but it would not work in Channels.
I am creating a custom channel with the text feature

Try changing the stream type from HLS to MPEG-TS.

Yes i tried that.

I figured it. Hope this helps someone else.
rtsp://admin:[email protected]:554/Streaming/Channels/1?

LTS CMIP8212B Camera

Good Luck



I got this working with my Unifi cams, but, how does one set the channel number?
Looking at other threads, i see many examples posts like this one:
#EXTINF:-1 channel-id="Backyard" channel-number="1.4" tvg-name="Backyard" tvc-guide-title="Backyard" tvc-guide-description="Live view from Backyard"

those tags, however, it won't work. the guide just shows that whole line of text, and still sets it as a 9000 channel.

1 Like

This is what I use as mine ....

#EXTINF:-1 channel-id="Office Camera" channel-number="1.1" tvc-guide-placeholders="86400",Office Camera


Though, it says no channels found.

Until i added a '#" before the very first line, so #EXTM3U

which also is how the example text in the settings dialog has it.

Yeah miss that with paste

This works fine for local LAN cams, but not remote cams.

I get "Tuner not available" message when i try to play the channel.
The web ui does re-connecting, for a few secs, but then stops.

I guess Channels timeout is set too fast for this use case.

I can play the remote cam fine in VLC, most of the time. It does take a few to several secs to load and sometimes does not.

It URL is like this : rtsp://{DDNS domain}:7447/xxxxxxxxxxxxxxx

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.