Live TV Keyboard Shortcut Causing App Restart on Shield

Using FLIRC receiver on Shield Pro to control Channels client. We need the numeric keypad to operate on universal remote for fav channel buttons.

All keyboard commands work great except for Live TV shortcut. Live TV assigned to F2 under settings/general/remote shortcuts. When pressed, last channel streams for few about 5 seconds then app appears to re-launch or restart. This behavior was observed on 2 different Shield Pro's.

Haven't tried any other Android TV units. Can anyone else confirm this behavior using an attached keyboard with Live TV remote shortcut?

***This may be related to the Live TV issue in current build on Shield. 4.5.1 I'm able to launch Live TV manually by selecting a channel from guide or on now but NOT from remote shortcut. F1-F4

** Installed beta version, Live TV keyboard shortcut causes crash on beta, not re-launch. Both stable and beta don't work

Please submit diagnostics from the beta after experiencing the crash

Crash report submitted. Please let us know what you find and if a new beta/stable has been pushed. Thanks

Hi is there an update on this issue?


1 Like

Please submit diagnostics again from the SHIELD after the crash

That was done 10 days ago when first requested. We will submit again.

Yes I saw that one but it didn't help.

Resubmitted diagnostic after crash from Live TV remote shortcut press F2

Pressing F2 starts live tv for a few seconds then app appears to launch with “preparing your TV”

Any way to resolve this? Or is there a beta we can try?

See attached photos in sequence

Personally, the "Live TV" option on Android has always been error/crash prone. While it sometimes works, it has never been consistent.

My opinion: use it as a "sometimes" option, but never something to depend upon

If you can select a channel and watch Live TV with a remote reliably on Android TV, not sure what the difference would be triggering the same function/routine within the app from a keyboard command?

Remote shortcuts have been present within all the client apps for a long long time. Other functions work- guide, dvr recordings etc, just not Live TV.

I’m sure the developers have an Android TV and a keyboard in house to replicate this behavior? I don’t think it’s limited to Shields.


Was hoping new beta release for shield would fix remote shortcut for Live TV bug but it doesn’t.

After playing last channel for 2-3 seconds, app crashes/restarts when F2 is pressed and assigned to Live TV.

Feedback on this issue would be appreciated.

I tried this with F2 and its working for me. It launches the player the first time. If I'm in the player, it goes to the previous channel.

EDIT: Tested again with video decoder set to Hardware and that also works without crashing. I am testing with HDHR PRIME channels and Tuner Sharing set to On

Tried another keyboard and I am able to replicate. Will take a look.

1 Like

Try this build:

I can confirm that the Live TV remote shortcut bug is fixed in latest beta for Android TV. Thank you! When can we expect this to be available as stable on Google Play?