Local Content source added to Channels DVR Server is not displayed in Android Channels app

Hi all - new to Channels but excited about the direction and enthusiasm from the community. I have the Channels DVR installed on my QNAP NAS and Channels app installed on my Tivo Stream 4K (Android) device. I have my HDHR and TV Anywhere source setup and working from Xfinity. Recording, etc. all works.

I've turned my attention to importing my DVD library, which are each saved as an MPEG-2 Program Stream with single AC-3 audio track. To be clear, a single file, not the standard DVD disc structure. From the DVR Server settings, I have /share/movies added as a source. My directory structure is guided from the Plex recommendations:

/share/movies/TITLE (year)/

Each movie directory has the movie file, and a Folder.jpg which has the poster art.

/share/movies/TITLE (year)/TITLE (year).mpg
/share/movies/TITLE (year)/Folder.jpg

I wasn't sure if the video format had anything to do with it, so I also tried multiplexing the mpeg2 video and ac3 audio into an MKV file and place in the directory structure as TITLE (year).mkv. I don't see these being picked up and displayed anywhere also. I then tried an AVC (h.264) encoded video as an MP4 in the same structure and still nothing.

So I'd value input from this community. I suspect I'm missing something obvious. I've searched many different topics in the community forums but nothing answers these questions I have below that I was able to find.

  1. Does the Channels app from the Android TV store work out of the box, or do I need to side load a Beta version of the app for the movies to be displayed on the client?

  2. Does the media groveler on the DVR Server care about the video encoding, or is based on directory structure/metadata?

  3. Is there additional metadata I need to add for the groveler to pick up the movies?

I am running the latest DVR Server: ChannelsDVR_1.0.3.qpkg.

Thanks in advance!

Does the Log tab show any errors?

No errors in the log.

I see no log entries with the movies share path anywhere (if that is supposed to be logged), or any with the text "Local Libraries". The only error pattern I see repeating occasionally (but doesn't give any hints about Local Content) is:

2021/01/09 10:52:45.697602 [TVE] action=authed
2021/01/09 10:52:45.697626 [TVE] action=wait_for_page done=true reason=auth_finished
2021/01/09 10:52:45.699731 [TVE] action=cookies num_domains=2 num_cookies=27
2021/01/09 10:52:45.711683 [TVE] action=error_response type=Document error=net::ERR_ABORTED

I'm happy to collect/share traces with instructions, or adjust the verbosity level of the logs via CLI if given instructions. Also: where exactly would my movies be shown in the Android TV app? I have been assuming it's in Library.


Please click Support > Submit Diagnostics on the DVR web UI at the top right and we can take a look.

Log: 7a471e5a-a85d-4e85-9e8b-91c3aea750cd

Can you try clicking the dropdown next to Check for Updates and select Pre-release

Updated to Pre-Release and got 2021.01.12.0032.
No errors in the log and also no log activity related to Local Content or Movie sources. Don't see any sign of local content in Android TV app.

New diagnostics submitted after update to pre-release: 183e9dbf-3a8d-4484-9c38-9376938433bf

Seems like the directory is not being scanned. Perhaps a permissions issue?

We log all errors except "no such file or directory" so that path is incorrect or inaccessible by the dvr process

Does the DVR server run under a specific user account? I assume this would be expressed as part of the application manifest as part of application install. From output of 'ps aux' I can't identify the process this service is running as, and nearly all long running processes except the web server are running as admin.

I verified the /share/DVR directory that recorded TV is saved to has the same permission as the /share/Movies directory. For kicks, I set to chmod -R 666 just to be extra sure, and still see no log events flagging anything, and still not seeing local content enumerating anywhere. This could be a good area to increase verbosity of logs =)

Because I know the DVR directory is working, I tried to add a Movies directory under this location (/share/DVR/Movies), but this is disallowed from the log entry:
[WRN] Scanner ignoring movies path inside DVR folder: /share/DVR/Movies

I checked system logs and do not see any access errors. On these QNAP NAS devices, pretty much everything is sent to /share/Logs/messages.

Do I need to re-spin the DVR server process? If so, how? (sorry if this is answered elsewhere in the community).

At this point, I'm having trouble identifying a permissions related unless the DVR server process is running under a different account. To keep everything simple, I have only 3 movies in /share/Movies and I have all files and directories set as:
chown -R admin *
chgrp -R administrator *
chmod -R 666 *

Is write access required for local content directories, or only read?


maybe it's movies vs Movies that's the issue

P.S. happy to take this to an email if that's best =)

The case is set properly in the Channels DVR server config page as I can only select existing directories from a drop menu. Is it correct that the only settings configuration is on the DVR server page, and under the "Local Content (Beta)" heading?

In the picker do the movie folders appear?

Yes, I set the path for Movie Sources using the picker, and chose /share/Movies from that path.

Final things I've tried with no luck:

  1. Changed user/group to guest account as one more thing to try (I literally only have admin and guest accounts on this box), with chmod -R 666 *.

  2. Moved to a new directory not named Movies or movies with RW permissions for user/group.

  3. Tried with Android mobile and iPhone apps.

Still nada.
By any chance is bonjour discovery required here? I am manually entering the IP address of the server on every client.

Could very well be that QNAP introduced a regression on recent firmware update.

When you select it in the picker, the movie directories are shown? Can you post some screenshots of the directory structure? I know you provided examples earlier but I'm just trying to make sure.

Correct, when I select "Movies" from the top-level "share" directory, each directory that represents each movie is visible to the picker. See the screenshot. As described earlier, within each movie directory there exists two files, a mpg file named the same as the movie directory and a JPG.

As there are no sub-directories under each movie title [e.g. King Kong (2005)], when I choose any of these directories in the picker, it shows an empty set as I expect. I am; however, able to open each of these directories within the picker, which suggests to me that the application has permission to read.

You didn't mention if they show up in the DVR web UI.
If you look at Recordings>Imports is anything showing up there?

What is this web UI you speak of? =)

Where the import picker is

Sorry, not seeing anything obvious. Can you show me what the link is? At the top of the page, I see things like Settings, On Now, Guide, etc. Nowhere do I see Imports.