Lollipop support

I see that Android 5.1 is the minimum for the DVR client. Any idea how long before 5.1 support is dropped?

Someone has a Galaxy View for sale cheap nearby, and I'm wondering if it would make an interesting small TV. Its biggest limitation is that Samsung left it on Android 5.1. (Though other Galaxy Views have slightly newer alternative ROMs, this is the AT&T version that doesn't)

We plan to keep support as-is, since older FireTV hardware is 5.1 based.