Long delay tuning ATSC3 channels after HDHomeRun firmware update

I’ve been using an HDHomeRun Flex 4k tuner for 1 week (sent by Silicondust as warranty replacement of my failing HDHomeRun Flex Quatro) and it was working great with the Channels Apple TV beta app. All the network affiliates in the Washington DC area are broadcasting in ATSC3, and I switched my Channel Collections to use the 3.0 channels instead of the ATSC1 channels.

My HDHomeRUn Flex 4k had then-current 20221205 firmware, but a couple of days ago I updated its firmware to the new 20230303 version. I immediately noticed that with the new firmware it takes a very long time to tune in ATSC3 channels on the Channels Apple TV beta app, as much as 20 seconds every time. Once it starts it plays fine. With the previous Flex 4k firmware, the Apple TV beta app (which I have been using all along) was able to tune in ATSC3 channels just as quickly as ATSC1 channels, in less than 2 seconds.

At first I thought the issue was a problem with the HDHomeRun Flex 4k 20230303 firmware upgrade (and I was going to try and downgrade it) but the HDHomeRun Windows and iOS apps still do not have any delay in tuning ATSC3 channels, its occurring only with the Channels Apple TV app (on 2 separate ATVs).


We are aware of issues caused by the new firmware and are looking into it.


If additional logs help, I'm seeing the same issue.

2023/03/06 10:03:33.723150 New diagnostic log submitted under 931bb927-bf05-4e50-ac2b-7e93f672dba0


Thank you for quickly confirming there is an issue. Do you perhaps know if the HDHomeRun firmware can be rolled back to the 20221205 version (i.e. using their 'HDHomeRun Config GUI' App)? I've looked all over the Silicondust website (I think) and I can't find downloadable previous firmware versions.

They don't allow rolling back firmware.

1 Like

If you use Windows Install you can find the Firmware here ... C:\Program Files\Silicondust\HDHomeRun

1 Like

Thank you for the tip! That folder didn’t contain any 20221205 firmware versions in my case (just the latest 20230303 and 20221023), but by studying the URLs on the Silicondust beta downloads page I figured out the location for the 20221205 firmware for my Flex 4k:

The “HDHomeRun Config GUI” Windows app accepted that file and it seemed to successfully install it on my Flex 4k (Downloading... Upgrading... Rebooting... Upgrade Succeeded) but after the reboot my Flex 4k was still on the 20230303 firmware.

I also tried other variations of the 20221205 firmware (i.e. hdhomerun5_atsc3_, hdhomerun_atsc_) but the app rejected all of them, the “dvr_atsc3” versions are the only ones it accepted for the Flex 4k.

Then I tried installing the previous version of the Windows apps (from before the 20230303 firmware was released) from here:
But it did the same exact thing as the latest version of the app.

I guess Aman wasn’t kidding when he said Silicondust does not allow downgrading firmware!

Hopefully Aman and company (by far the best customer support I’ve ever seen!) will quickly figure out the issues caused by the new HDHomeRun firmware, until then I’ll just have to wait 20+ seconds every time I tune to ATSC3 channels.

1 Like

I just updated my HDHomeRun Flex 4K firmware. Found this post after I too experienced the 30+ seconds delay when trying to go to an ATSC 3.0 channel.

Let me know if you need anything to assist with resolution.


Thank you for reporting this, with multiple users reporting this issue it will hopefully get priority. I also opened a trouble ticket with Silicondust but have not gotten a response yet.

1 Like

Do you have long tuning times using the HDHomeRun APP ? I do not so in my case it is a ChannelsDVR problem.

You’re welcome. I just submitted a ticket to SiliconDust also. FYI, I just tried using the HDHomeRun app on my iPad and there is no significant delay when going to an ATSC 3.0 channel - maybe a couple seconds at most. Not sure, but this may be helpful information leading to a solution in the Channels app software on Apple TV.

It's the same with me - the HDHomeRun Windows app tunes ATSC3 channels just as fast as it did when my Flex 4k had the 20221205 firmware (I mentioned this in my original post). Aman responded quickly on this thread, he said they are aware of the issues with the new firmware and are looking into it. Nevertheless this particular issue started when Silicondust updated their firmware, so I reported it to them also. But my guess is that Silicondust won't do anything about it and the Channels devs will have to work to accommodate whatever Silicondust changed/broke. Hopefully they will find a way, and soon!

I am sure Silicondust updated their firmware to fix ATSC 3.0 markets that were having problems ... 3rd party Software needs to adjust accordingly.

The new firmware is creating an issue. Specifically this change:

  • ATSC3 models: Reorder audio tracks for apps that use the first track rather than selecting the audio track by language.

We are trying to find a workaround but its not something simple.

Please let HDHR know the firmware update is causing issues. Maybe they will consider reverting that change. It was supposed to help with third party apps but has made things worse.

The root cause is that two audio tracks are advertised when only one is present. You can also contact your ATSC3 station and let them know their broadcast is incorrectly advertising one empty audio track.

1 Like

Aman - thank you for this info, it is greatly appreciated.

I already opened a ticket with Silicondust yesterday but I still have not gotten any response from them. I'll update the ticket with your additional info regarding the empty audio track, and I'll also try calling their support number.

I'm certain that if there is a way to work around this firmware "improvement" the Channels devs will find it!

Similar delays in Channels and HDHR ~16 seconds to tune HVEC channels, HD and SD channels are snappy in both Channels and HDHR software. Version 20230303 (1) on MacOS and TVOS

I downloaded the HDHomeRun app on my Apple TV also. It doesn’t have the delay issue for ATSC 3.0 channels either.

I submitted a ticket to SiliconDust today and they responded a few minutes ago asking me to try the HDHomeRun app to see if the delay exists. I sent them a reply telling them I tried it on my iPad and Apple TV and didn’t experience the issue.

Aman - I added your info ("root cause is that two audio tracks are advertised when only one is present") to my existing Silicondust ticket, and I got this response from them right away:

Thank you for that, we have relayed this to our development team.


I also passed along to SiliconDust the info Aman identified re: source of the problem. Hopefully the developers (SiliconDust and Channels) have enough feedback to figure out a solution for the end-users. Thanks for your support!