Lots of Stuttering and Buffering in DVR Playback on ATV4K

I need help figuring out why my Channels DVR experience has been so poor. I'm running the server on a Synology NAS (DS218+) and streaming to an AppleTV 4K. When I'm trying to watch a football game, I frequently can't skip forward 30 seconds, or if I do, then it takes around 30 seconds for it to buffer, making the skip pointless. Pressing the Skip Commercials button takes several minutes before it catches up, so that's totally not worth it.

I turned on the stats and I see a line that lists the cache. On my setup, that cache line comes and goes, and when it disappears, the playback of the show stutters. Then it will suddenly start building up a cache and as long as there are a few seconds of cache, the playback works great. If the cache gets above 30 seconds (rare) then I can skip ahead, but then after the next play, if I try to skip ahead again, I get buffering because the cache wasn't built up to 30 seconds yet.

The ATV is connected via wifi. I don't know how to test the internal speed of the network, but since it's just the speed of data going from one box in my house to another box in my house, even slow wifi should be plenty fast. So what am I doing wrong and how to I troubleshoot it to improve my experience?

Run an internal speed test like this:

https://getchannels.com/docs/getting-started/faqs/channels-apps/#how-can-i-test-the-network-speed-at-my-tv

Thanks. I'll do that tonight as soon as I get home and I'll post the results here.

I'm not sure what I'm doing wrong, but if I go to that URL 192.168.x.x:57000/speedtest I get "Safari cannot open the page because it could not connect to the server." and on Chrome I get "This site can't be reached. 192.168.x.x refused to connect."

Is the Channels app running on your TV. It has to be visible on the screen

And just in case there is any confusion. The IP address you're entering in that URL is the IP address of the AppleTV you're testing, not the IP address of the Channels DVR server.

Had an odd thing exactly like this on my Android TV device last week. Uninstalled and reinstalled the client and it fixed it.

Ah, that wasn't clear in the piece you linked to. I just thought I had to get the AppleTV IP address and then go to that URL on another device. It didn't say anything about the Channels app needing to be active. I'll try it again tonight.

Edit: Nevermind. Just went and looked at that link again and it does say to launch Channels. I could have sworn it didn't say that yesterday.

This had started happening on our Apple4k with the DVR running on an old laptop. None of this setup had changed in over 2 years. All updates were showing up-to-date, I reset everything as well as the local network. None of this worked. After reading the post above, I decided to delete the Channels app on the AppleTV and reinstall. This seems to have corrected the problem. Thank you!

Seeing a ton stuttering as well since updating to tvOS15. I ran a speed test and the numbers seem good:

When I use Show Stats feature, the cache seems to run out quickly and the connection stat next to that field is typically in the low single digits: 1-3mbps

I having trouble as well with my ATV4K Gen2. It makes sense now that it might be related to ios15 because I didn't have issues with it previously and my ATV4K 1 works fine on iOS14.7.

My issue specifically is playback will hang and not recover when trying to watch an in progress recording. It will also hang when automatically switching transcoding quality due to "Adaptive Streaming" since this Apple TV is remote.

crickets

Other than your screenshot, you have offered no other relevant details. You have an Apple TV on tvOS 15, but is it wired? Wireless? What is your network topology? Is this the only device with issues? Is your DVR up-to-date? Clients? TestFlight versions? Is "stuttering" your only issue? Which types of sources are you seeing this with? All sources? Only OTA? Was this immediately after your upgrade, or was there a period where quality was good after the upgrade to tvOS 15?

The crickets are chirping because they're waiting. If you want detailed help, you need to provide details about your issues. Troubleshooting is an interactive process, and those on the other side aren't clairvoyant; they only know what you tell them.

I offered up what was asked of the person experiencing the same issue as me. Thanks for sharing though.

They chirp audibly and are a good source of protein. Mmm

1 Like

Some people have reported that removing and reinstalling the app on tvOS helps.

I tried reinstalling the app. I'm pretty sure all the issues for me happened after tvOS15, I say pretty sure because I upgraded right before I went to bed and I don't use channels everyday. A firestick 4k, iphone and ipad (ios15 on both) work fine in the exact same network scenario, the apple TV is unusable, hangs 100% within 5 minutes when watching in progress recording, or hangs as soon as you seek to where you left off. It also hangs every time the adaptive transcoding changes streams. It is usable to watch stuff already recorded as long as the adaptive streaming doesn't change streams.

When it hangs are you able to exit the player back to the Channels app menus?

Could you submit diagnostics from the app after it hangs.

Have you tried it with adaptive streaming disabled? What about changing the transcoder to software? (I re-read your posts, but I don't recall seeing anything about you changing any settings, only stating what your settings were, IIRC.)

It works with adaptive streaming off for everything that isn't an in progress recording. I'll add that it works watching a live channel as well as long as it doesn't change streams. This apple TV is remote. I also have a local apple TV 4k gen1 on tvOS14.7 that works fine. Software or hardware transcoder doesn't make a difference.