Mac: How to uninstall?

I installed this onto my main laptop to try it but now want move it to another machine.

How do I uninstall? There should be some support for this somewhere. I see a script in the DVR folder but honestly, not that familiar on how to run that.

I can delete:
~/Library/LaunchAgents/com.getchannels.dvr.plist

and the folder I created but is that enough?

thanks!

Run ./channels-dvr/uninstall.sh

You probably also want to copy the .db files in ./channels-dvr/data if you’re trying to move your existing recordings and passes.

You need to run this from a Terminal Window (Terminal App).

hmm, tried it in a few different ways. keep getting command not found.

Please copy paste the transcript from terminal including the prompt, command and output.

[rosnow:~] rosnow% Run ./channels-dvr/uninstall.sh
Run: Command not found.
[rosnow:~] rosnow% cd channels-dvr
[rosnow:~/channels-dvr] rosnow% Run uninstall.sh
Run: Command not found.
[rosnow:~/channels-dvr] rosnow% Run ./channels-dvr/uninstall.sh
Run: Command not found.
[rosnow:~] rosnow% Run ./channels-dvr/uninstall.sh
Run: Command not found.
[rosnow:~] rosnow% Run /channels-dvr/uninstall.sh
Run: Command not found.

admit I can only fumble around with Terminal - still…

also, would an older iMac running 10.6 be sufficient as a DVR? I have a 2007 Core2Duo iMac that I could dedicate for this if that is enough…

Don’t type the “Run” part

10.6 is quite old and we haven’t tested with it. Other users have reported the core2duo is not sufficient for comskip or transcoding, but should be ok for recording and ATV playback.

ok guess that worked…

[rosnow-2:~] rosnow% ./channels-dvr/uninstall.sh
[rosnow-2:~] rosnow%

I tried running the install command on that machine but nothing happened :slight_smile:

The uninstall command produces no output, but you should see the DVR icon from the macOS menu bar at the top disappear. And ofcourse http://localhost:8089 will stop working as well.

Thanks

I cant seem to uninstall channels dvr with this method?

has it changed since beta?

Yes. To uninstall, download the setup utility from our website and run it again. It will detect the DVR and offer an uninstall option.

2 Likes

This did not work for me. Still trying to remove from tool bar. My computer doesn't see anything with the word "channels" in it anywhere but obviously there is since it's still on my tool bar???

In terminal:

~/Library/Application\ Support/ChannelsDVR/uninstall.sh