Maybe it's just my m3u?

Does anyone else have stuttering with m3u's?

I tried an IPTV service, stuttered.

I tried remapping my TVE channels as an m3u, stuttered.

Regular TVE works.
Regular hdhomerun works.

Seems like however the m3u's play is the issue, no?

I have one Channels-DVR "Server" (main). I have 3 instances of Channels-DVR, one for each member of the household. All three user instances of Channels-DVR use m3u's to connect back to the the main server without issue.

Something else must be going on. Can you post one of the channel configurations from the m3u?

Pretty basic I think...

The only difference I see from how mine is setup is the missing format=ts on the URL:

http://x.x.x.x:8089/devices/ANY/channels/6030/stream.mpg?format=ts

The stream.mpg implies MPEG-TS, so the additional query string is unnecessary.

@CircusBrain, your playlist looks pretty similar to how I have my channel redirects handled, and don't notice any lags. So, I think this might be more hardware/network related than a configuration issue within Channels.

I also have this set up and don't experience any lagging.

4 MiBox S's are my local clients and whether they're wireless, or wired through a USB/Ethernet NIC I get about 150mb/s up/down and no issues connecting to the server. I'm using the "original" setting for streaming quality and have tried setting the server to hardware / software and all 3 modes on the clients, nothing seems to make a difference although, with MiBox on Android 9, connecting to the HDHR, Channels Client HAS to be set to Software because of the MPEG2 codec bug they introduced.

Aight, so... I switched everything to software encoding and such and so far so good, maybe it's the mibox's just sucking...