My shield crashed tonight

I've had my Shield Pro as my server up and running for months with no issues. I never upgraded to 9.x because of all the horror stories and all has been well, until today... I couldn't connect to my server tonight for some reason. I was just getting a spinning circle when i tried going to I tried rebooting the Shield, nothing. I tried restoring the database from my PC but it never recognized my database folder. When I navigate to the folder from my PC, all the files along with the database folder are there. I'm not sure what i can do to get my system up and running again. Any one have any suggestions? I tried upgrading the DVR server from the Channels DVR Beta app in my Shield so I've got the latest version now.

Thanks in advance,

Reboot your router?

I have found my Shield to be my most unstable platform I have tested since the Nvidia v9. It needs to be rebooted almost daily. This has nothing to do with Channels.

Thanks, I figured it out by uninstalling the DVR app and then reinstalling it. Took me two tries, because once i did this i was able to restore my database from a day ago, but right after every died again. My second attempt consisted of simply clearing the app's memory as if it was reinstalled. Then i restored my database from two days ago and I've been up and running ever since! I did not ever upgrade my Shield to v9., i guess I'm one of the lucky ones