Need Help - Newbie at Raspberry Pi set up

I followed the instructions to the T from the YouTube video:

I think maybe the gentleman on the video skipped a step or something because the "dvr-server" is not coming up at all
Here is a video of me explaining what I have done and my setup:

Hopefully someone can help me figure this out.

(note: I also sent an email to support, if they figure it out I will update this thread)

Thank You

You need to get the IP address of the Raspberry Pi. Once you got that. You put in the url whatever your IP address is and port 8089. So for example, is what you would put in your address bar in Chrome. If that were your IP address.

Would you happen to know how I would get the IP address of my Raspberry Pi?

You would need to go into your router’s gateway and see what the IP address is coming up as.

Thank You. I tried to do exactly what you stated. Here is where I am at now with this:

The video shows your raspberry pi is offline to the router. Try unplugging and plugging back in the pi power supply. Then look back in your router to see if it shows online. Then repeat what you did to get the ipv4 address in the router

I unplugged it and plugged it back up and now it is just blinking. Its been doing so for 20 plus minutes now. So now there's that going on

Try flashing the drive again.

Have you tried plugging the HDMI output of the Pi into a monitor so you can watch the console messages as it boots/runs?


I just flashed the drive (Samsung 1TB Shield) and its still just blinking

How exactly is it blinking?

See Channels Support - Raspbery Pi Installation

The green LED on the front of the Raspberry Pi will go through the following sequence after power-on:

  1. RPI EEPROM booting: solid green (~5 seconds)
  2. U-Boot booting: solid black (~5 seconds)
  3. Linux Kernel booting: solid green (~5 seconds)
  4. OS booting: black flashing green (~10 seconds)
  5. Waiting for NTP time sync: green flashing black
  6. DVR active: solid green

The DVR web interface on http://dvr-server is accessible as soon as the OS boots (step 4), approximately 25-30s after the Pi is powered on.

Here is the flashing green light

Looks like its stuck on step 5 then, trying to sync the current time.

Do you have a micro HDMI you can plug into a TV to confirm?

Is there any adblocker running on your network which may be interfering? Or custom DNS on your router?

Is the light on the back next to the ethernet cable on?

  • I just brought a micro HDMI and going to plug it up to the TV now
  • Ad blocker running on the network? I don't know. How would I find out?
  • Same question about custom DNS. I don't know what that is exactly and how I would find out.
  • The light on the back of the ethernet cable is on, its green on one side and yellow on the other (on the R pi box) on the modem its green

Okay that means it has ethernet link.

If you haven't set up adblocker or custom dns manually it shouldn't be an issue.

The HDMI output will be the best way to figure out what's getting stuck.

Here is what the screen said when I unplugged it and plugged it back up (R Pi box) and had it connected to this monitor.


I got it to come up, but here is my next issue:

I think you need to reflash the usb drive again. Pi images are finicky and sometimes it takes 3+ times for one to work right. My understanding is there is supposed to be a folder for storage by default under media/dvr. I don’t use the pi for a server so maybe someone else can confirm that folder is there on the channels image for pi

Thank you everyone for your assistance. But after trying everything I just gave up. I am returning all of the raspberry pi equipment.

For what it's worth, I purchased a HD homerun 4k flex & I was using the USB slot on the box to power the antenna but after a bit of research it was discovered that the this particular model was made to use USB storage with it. So I erased the drive through utility fix on my MacBook pro, plugged it into the HD homerun 4k flex, signed up for their service, followed the instructions on their website & voila. I had the ability to record live TV.

I thought this process with the raspberry pi would have been an equally easy process but unfortunately I couldn't make it work.

Thank everyone for their help.