Network issue - can't open the page DVR server after crashing due to second drive with Local Content

I'm having a baffling network issue. 2 days ago...everything working totally fine. Then yesterday, I can't connect at all to the server on the Raspberry Pi.

My router UI is saying the dvr-server ethernet connection is inactive. The lights on the Pi for the ethernet are blinking green and solid amber.

I've tried swapping the cables and ports on my router with my HD Homerun which is connected fine.

Can someone tell me next steps?

Try getting the IP from your routers interface and connect using the IP. For example with IP

If that fails, try restarting the PI.

Good luck

1 Like

Thanks, Morris. Yeah that gives me the same server where this page is located isn't responding message.

I've tried re-starting the PI many times. No luck.

You probably need to attach a hdmi cable to see what's happening

1 Like

Thanks. Waiting for it to arrive from Amazon.

Okay, so I'm seeing an "Invalid Format" graphic.

1 Like

Weird I hven't seen that before. Wht happens if you plug in hdmi before powering the pi

That is what I did to get this result.

Isn't that the tv/monitor message meaning the input format (resolution) is not supported on your tv. The Pi does not display that kinda graphic. Try using a normal HDMI computer monitor or a different tv.
Might also be a bad cable.

It's working now. I had another additional hard drive on my PI (from a previous migration) that I think was screwing things up. I disconnected that, and now it's up and running. Thanks!

Actually, now the same thing is recurring. I reformatted the drive for my local content. This drive is plugged into the Raspberry Pi. I re-added the sources for TV and Movie. It re-scanned everything.

Then I went to watch a movie from the local content. Everything worked great for about 45 minutes. Then all of a sudden the movie stopped playing (I can't tell if it was at the end, or it crashed). After that, I couldn't get the DVR to respond. I had to unplug the secondary hard drive, and then re-start the PI for it to work again.

So, this is some problem around local content on a second drive.

Are you using a POWERD drive on the pi? The Pis usb can not provide enough power to run mechanical drives stably. You need those attached to a powered usb hub, or use a drive with a independent power source. Or use external ssd, like a Samsung T7, those can be powered off the Pi no issue.

I was having issues with a mechanical drive previously and things would cut out (but it wouldn't make the whole DVR inaccessible). So, I switched to a SSD that Channels recommends: KOOTION 1TB External SSD Hard Drive USB 3.1 Type-c.

This is what I'm using now and getting this new issue. I am running 2 of them. One for the server and the other for additional local content. I'd think the pi can handle accessing 2 of these, but maybe not?

If the drive is disconnecting, which would cause the server to not be responsive, suspect it’s a bad or just crappy drive. Never heard of that brand and doesn’t have that many reviews.
Stick with name brand trusted drives not some random Chinese brand.
That drive comes up as $112 on Amazon whereas I’ve seen Samsung and SanDisk brands for around 80 or less. A WD portable ssd 1TB on amazon is $60. A Samsung T7 1tb, which is much faster than no name, is $80. (i used a T7 500GB)
Where does Channels recommend this particular Chinese brand SSD?
The only thing on the Channels web page under the Pi page is "WD Elements 4TB Hard Drive" and that is a powered drive.

Often those no name China drives are fake, and just a crappy micro-sd card on a pcb with a controller chip programmed to say it is larger than it really is, and when u write data to it, it starts overwriting existing data, and when u try to read that data back, ie play a video, it just craps the bed. (look at YT videos on Amazon ssd scams etc)

If you can submit diagnostics from the server that would help show what’s happening or perhaps have an HDMI hooked up to another monitor to observe anything displayed when it does crash.

1 Like

On this page: Channels Support - Raspbery Pi Installation All the way at the bottom " Secondary Pi OS drive

  1. Purchase a small/inexpensive (~60GB) SSD drive and prepare it using the instructions above
  2. Boot your Pi off the SSD
  3. Attach your existing DVR drive to the second USB3 port
  4. Visit http://dvr-server:8089/restore and select the most recent backup from the Database folder on your old drive

Interesting, but probably old, seeing as it says ~ 60GB ssd drive and it links to a 1tb drive. The listing probably changed over time. And, for sure, not the best deal out there. My recommendation still stands.

Only other issue I would suspect, is the PSU you use to power the Pi. Is it a reputable one? Like from CannaKit or the Official Pi branded one? Or some generic one? I think the Pi needs a 3.5A usb C adapter. Pis are known to be sensitive to not so to spec USB C power adapters. Random ones that comes with those cheap cases sometimes are not to spec. (the canna kit one is 3.5Amp, but i have used as low as 3Amp fine with a single ssd)

If adding a 2nd drive to the mix, for sure, is causing your issues, and removing it solves it, then, high chance it is a power issue.

Cool. Thanks for the info!