NEW: Channels DVR backend for Nvidia SHIELD


#41

@DebbieFL - I don’t know if this will apply in your case, but I have occasionally had ARM board disk drops due to power issues associated with a 2.5" drive with USB power. This were solved by using a powered USB hub.


#42

Great idea. Thank you :blush:


#43

Mine definitely isn’t using it. I have a 256GB SSD plugged in and formatted for internal storage, but it’s all on the real internal. Plex is the same in that it has to use the real internal and not a drive you formatted for internal storage.

You can add a folder on your formatted for “internal storage” drive (and possibly external… I haven’t tried) that’s an empty folder, add that to your Library, and have the Shield put the “optimized” version there. Then when it’s done I just mount the share and copy the “optimized” version of my DVR file to my NAS. It keeps the filesizes smaller since my kids want to keep every episode of every show they watch forever, and the only downside is no commercial skipping.


#44

@DebbieFL The internal storage of the Shield is a weird thing. It doesn’t look like you’re using it, and doesn’t report as a larger disk space. However, the Shield creates this virtual disk structure that over time shifts things across to the external drive. It really doesn’t look like it’s being used, but you’ll suddenly realize you have put 2 TB of data and it’s handling it invisibly.


#45

Known issue, should be fixed in next build.


#46

Can’t seem to restore a backup on Shield:

Log:
2017/05/22 19:48:50 [ERR] Failed to read directory: open /storage/DCA07F46A07F2664: permission denied


#47

@tmm1 @karlmitchell @timstephens24

More info on my Shield setup

Apps: Both in original storage (=11gb)

Channels Storage = .6GB
Plex Storage = 1.7GB
+others
=6.7 free

Some other of my apps are stored on the “internal (adopted)” SDXC card

PLAYBACK:
Simultaneous testing with three recordings (only have 3 tuners), processing/com skip 1 recording, and channels play of recording at 1080 @10mbps (was>1.0x)

Priceless


#48

I don’t have a problem with my recovery directory. Weird…

https://stephens.cc/images/screenshot_shield.png


#49

Actually after comparing, don’t you need to select the directory above where you are and not clicking on a backup? Go up a directory, click Load, then it’ll give you another screen to choose the backup.


#50

None of the other SHIELD’s I’ve seen have a /storage/SHIELD. They all have /storage/XXXX-XXXX. For some reason your’s is different with /storage/DCAXXXXX, so things are not working correctly.


#51

I’ll try rename of 4tb device to XXXX-XXXX…hopefully, that will fix it.


#52

Renaming the drive will not help… the name is chosen by the OS automatically. Wait for the next build, which should let you restore from within /storage/DCA*/NVIDIA_SHIELD


#53

Ah, for that and forcing a non selectable user password I’ll call the Shield “POS”


#54

v2017.05.22.2051 is now available.


#55

Tried reformatting the 4tb drive (non quick on SP Pro 3), after 2 hours it is less than 25% done. I’m going to cancel and again do a quick format for NTFS. Will then do a reload of DVR after attaching to Shield

One thing I noticed that On previously quick format, I was not able to connect to the network share for this drive on my iMac7, although I do have a NTFS reader on iMac.

Expect same results as prior (DCA*), although now should be able to try with newly released DVR build to hopefully restore database on the DCA* share. If ok, then will copy over the balance of DVR directory from Qnap and continue from there.


#56

Complete bust. Cannot connect. Will try again tomorrow.


#57

What are steps you have used to connect to “local-storage (internal)” disk on Nvidia shield?

I am totally frustrated with Win10 and Shield (POS)!


#58

Thanks for the fix, however:

After I blew out the initial setup and did a complete re-install…guess what?

My “new” machine assigned directory is “14F62272F6225470”, no longer begins with “DCA*”

Frustrating for both of us???


#59

Oof. Send me output of /system/disk and I will fix in the morning


#60

How about “ugh”.

BTW:

Time codes are working - Yay

FYI: The X (to delete a search parameter) is not in these builds, just a reminder for beta/production builds.

Still can’t connect to Shield as “network storage” nor was I able to map a network drive in Win10.

May have to blow out this disk also and assign a proper name to disk during format on Win10. Tried 1239-4000 on quick format, before your answer re: machine assigned name on Shield.

Additionally, the old DCA* is still appearing as an option when trying to setup DVR storage…expect the 14F* will also appear tomorrow after reformat/reinstall.

Not going to do anything else until I hear from you. Qnap will suffice for now.