New PI 4 and New Channels DVR install

I just bought a Pi 4B 4GB. I setup to boot from USB, wrote Channels DVR image to USB and have this started up. I logged into console with user: root.
The networking does not seem to be working. I tried the command ifconfig and the terminal does not recognize it. Does this distro have a package manager such as YUM or APT?

I figured I could just edit the dhclient.conf file to give myself a static IP Address and see if that works, but the file keeps opening as read only, even as the root user. Any tips there?

There is no package manager. Also, networking is handled by NetworkManager.

What does ip addr show?

1 Like

Forgive my laziness LOL.

1 Like

Interesting, my install says "Error: NetworkManager is not running."

Then perhaps:
# systemctl status NetworkManager
to see why it isn't running, or
# systemctl restart NetworkManager
to ensure it's running.

1 Like

Does systemctl status show any errors? Could be the install didn't work and you need to reimage.

1 Like

Failed to mount HassOS overlay partition.
Job result is dependency.
Dependency failed for NetworkManager persistent system connections.
Dependency failed for NetworkManager.
Dependency failed for Hostname persistent configuration.
Dependency failed for Hosts persistent configuration.

There should be no errors. Could you try reimage

Sounds like you ought to reimage ... and maybe take a checksum of both the image and disk to ensure they're the same.

I re-imaged this drive once already to get past another Time Sync error that was holding up the Boot Sequence. I'll try another drive completely and see how things go. Thanks.

OK, I can confirm, it was somehow the disk. Even though I re-imaged it a few times and it validated after write each time, something was just messed up with it. I tested successfully with an alternate disk. Thanks all.

1 Like

I had tried using an externally powered WD MyBook drive as a boot drive for a Pi (both with the Channels image, as well as separately), and was never able to get a consistent boot with it. Using a different/better drive alleviated my problems.

1 Like