NEW: Roku app for Channels DVR (experimental)


#41

If you get a chance, try switching the DVR to Software transcoding and see if that makes any difference.


#42

After switching the DVR transcoding from hardware to software, channels and recordings run at full speed (ones that actually start playing at all), but seem to stop to buffer for a couple seconds a few times a minute.


#43

I just tried to run it in my Wife’s Roku. The build says 2016 06220000. Looks like a typo. Anyway I can’t see the Dvr. Have it on a routed wireless. Any clues on what I need to open up before I have to setup a packet monitor?

I just ordered a moca 2 adapter, so that will eventually solve the problem. My iPhone on the same network Sees the Dvr.


#44

Good catch, never updated since I wrote the initial Roku prototype last year.

The discovery uses a UDP broadcast on port 8899. Would expect this to work on both wireless and wired, so not sure why it’s acting so unreliable on some networks. Perhaps I need to send more than one broadcast… I’ve seen both Bonjour and the HDHR discovery send out atleast 2-3 broadcasts in case the first is dropped.


#45

Since my network is routed, the broadcasts aren’t going to make it. I do have a bonjour proxy, that’s why my iOS devices work. I need to move that roku on to the IoT network, I was just being lazy. Since I’m replacing it with an ATV when the 5s hit.

My MoCA adapter arrives Tuesday. Without that, I would need to be able to configure a static IP, just like I do on the iOS devices with the HDHRs.


#46

I just realized the Roku TV can decode mpeg2 directly, so I’ve just uploaded a new version of the app which detects that and plays back the stream without requiring the DVR to convert it to h264. Give it a go and let me know how it performs.


#47

Pulled down the latest update, but now nothing will play. When I select a show, the black screen comes up with the program thumbnail and description on the screen and the purple retrieving bar at around 1/8 full. The logo and description disappear after about a second, but then nothing happens. The progress bar never moves from its original position of about 1/8 full. I’ve tried a few shows (live and DVR) and also let it sit at this screen for quite a while.


#48

Can you try the built-in Roku Media Player and see if it plays off your HDHR.


#49

I’ll give it a shot later today and let you know.


#50

Thanks. Also, when you use the Channels app on Roku, what does the DVR say on the Settings page under Activity?


#51

Okay, so here’s the update:

Using the Roku media player, I am able to watch the channels on my HDHR Connect. However when I choose any channel on my HDHR Prime, I receive a message saying the file is missing or corrupt. I am able to use other DLNA viewers in my home to watch the channels from the HDHR Prime, just not the Roku Media Player.

When I try to tune a channel in the Channels Roku app, the status on the Channels DVR web GUI says it’s watching whatever channel it is I chose. If I back out of the black screen in the app, the status stays stuck. If I keep attempting channels, the DVR’s status says they’re all being watched. It’s not actually using up any tuners on my HDHRs though. The only way to clear the status is to stop the DVR service and restart it.


#52

Hmm, interesting. Can you check your PRIME on https://my.hdhomerun.com and look at the Channel Lineup to see how many channels are listed as AVC? Are those the ones that don’t work? Usually local channels are mpeg2, and I would expect those to work atleast.


#53

7 of my 414 channels are AVC, and none of them are the ones I’ve been trying to watch (they’re Spanish channels).


#54

Presumably the Channels app then also works with channels from your CONNECT? (Ones that you favorite in the DVR first, so they show up)


#55

I uploaded a new build that disables the mpeg2 playback on TCL roku tvs, since it doesn’t seem to be reliable.

So we’re back to using the DVR to convert to h264, but now it should force h264 level 4.1. Seems to work well via my QNAP on my Roku Express.


#56

That is correct.


#57

Okay, I’ve updated. The behavior is exactly as it was before. Some channels will load but will play in slow motion, with real-time audio. Most channels will not start at all.

One thing I noticed this time is that the DVR activity while a channel is playing in slow motion says :“Watching ch1008 from192.168.1.137 (Running: 5.3053s @ 0.493x)”


#58

Hmm, is your transcoder back to Hardware now? What does it say in the Log for one of the channels that doesn’t play or plays slowly.


#59

You can try setting your Deinterlacer to Blend. Perhaps the roku tv doesn’t like 60fps feeds.


#60

Oops, I meant to mention that the behaviors I was seeing between hardware and software before are also in effect. Doesn’t work at all when set to hardware, works as documented with software.

Changing it from linear to either blend or hardware deinterlacing works, but it runs at only 30fps as you mentioned, and the picture quality is definitely degraded.

I think it’s safe to say that the TCL-Roku TV just can’t handle 60fps. Perhaps the channels app may need to be restricted to newer Rokus to ensure performance.