No audio to HomePod with 11.4


#21

Has this been fixed for others? I continue to have the problem where I have to re-select the HomePod every time the Apple TV wakes up from sleep. This problem occurs only with Channels and not other apps. I was hoping this would be fixed in the latest AppleTV update, but the problem remains for me.


#22

So it works fine until you force the ATV to sleep and wake it back up? Then it won’t play to the HomePod automatically until you reselect it? Does it show as already selected when you try to select it again?

How does quit/restart the app affect things (by clicking TV/Home twice and swiping up). If you quit/restart before sleeping, does it still send sound to the correct place? What about after sleep+wake, does restarting the app help or do you still have to re-select the HomePod?


#23

I ran some tests here and it seems like this is a bug in tvOS. I have opened a bug report with Apple to see what they say (here’s a copy: https://openradar.appspot.com/radar?id=5024558297907200)


#24

Have also been experiencing this problem, but HomePods work fine on HBO GO, Netflix, DIRECTV NOW, etc. As you say, if you swipe out the app it sometimes recovers, but not always. Seems more like a Channels App issue given the other apps are fine. It would be nice if the Channels app could support the swipe down audio selection like Netflix and HBO, much nicer than using an iPhone to select the audio output. That said, Channels is a great overall DVR/Set-top solution!


#25

I am also experiencing the Airplay problem after the Apple TV sleeps. I will play a recording in Channels and the sound will be routed to the HDMI port. I will use the Apple TV remote to adjust the volume and the AirPlay volume box comes up in the upper right showing the HomePod volume going up or down but in reality, the volume stays the same level outputting over HDMI. I then exit the Channels app, press and hold the Play button, deselect the HomePod, reselect the HomePod and then go back to Channels and the volume is going back to the HomePod again. My Apple TV is on tvOS 12.1 Beta and I am using Channels Beta app.


#26

Any update on the Airplay problem after Apple TV sleeps? I am experiencing this problem with Channels and TVos 12.1.1.

Some more info. Channels reverts to HDMI audio output even though I have the AppleTV audio settings are configured to send audio to Airplay to the Homepod. When using the remote for volume changes the AppleTV behaves as if it using airplay even though the audio is being sent to HDMI. At the same time other apps like DirectvNow and Infuse continue to send audio to the Homepod as expected. Going back to the Settings and unselecting and selecting the Homepod within the Airplay audio resolves the issue until the AppleTV is put to sleep again.

For myself it isn't a big deal to reset Airplay audio, but this workaround is more then I expect of less technical family members. The reason we have Apple products and the Channels application is for ease of use relative to other options.

Is there something that could be done to reset or force audio every time channels is restarted? Thanks.


#27

We're still waiting to hear back from Apple about the bug report. We reproduced it in a very simple 50 line application and sent it to them. It happens every time after sleep on multiple versions of tvOS and on both ATV4 and ATV4K.


#28

Thanks for the quick response. Hopefully Apple will fix this soon.


#29

Just bought Channels today and am kind of bummed about this problem - MrMC/Kodi also have the same exact problem (HomePod stops working after sleep), and Infuse used to before they updated to support AirPlay 2 properly in November. I don't know if you can consider this an Apple bug (certainly not one that they will do anything about) since there are many other applications using custom video players that support AirPlay 2 properly now. You have to do some work to get AirPlay 2 supported and it seems like this app and MrMC both are still using the old AirPlay 1 implementation which is pretty much broken now.