No audio to HomePod with 11.4


#1

I have been Airplaying my Audio to my HomePod for a while now. It has been fine, besides the slight delay of Airplay 1. Today, after updating the HomePod to 11.4, there is no longer any sound from Channels when Airplaying to HomePod. Other Apps are outputting sound. It seems that Channels needs to be updated to support Airplay 2. Using tvOS 11.4 and Channels beta 2018 (5.18.1857)


#2

Me too. I just bought a 2nd HomePod, Airplay 2 for stereo pairing is fantastic.
Downloaded Apple tvOS 11.4. on the Apple TV 4 – Sounds great. Except on the Channels app.
The audio is out-of sync by about 1 or 2 seconds. I have re-downloaded the Channels app, restarted the HDhomerun box, restarted all equipment. Other apps I have tried, all audio syncs beautifully. The Channels app seems to be the only problem.
Hey guys – an update required ASAP please!


#3

Sounds like two different issues here? One report of no audio at all, vs sync issues.

Can you try the VLC app on your Apple TV. Under the Network tab you can connect to your HDHR. See if audio is in sync or not.


#4

I’m also having the out-of-sync audio delay issue in the Channels app on my Apple TV since 11.4. I have two HomePods in the same room paired as one set. I updated the software of the HomePods, as well. Other apps (YouTube, HBO, Computers/Home Sharing) work fine.

I’d love to try the VLC troubleshooting step, but I’m having problems with the instructions. There’s a “Local Network” tab which shows shared computers using the SMB protocol and “Network Stream” which simply lets you enter a URL. Where should I be able to connect to my HDHR from VLC on Apple TV?


#5

Hmm you should be able to browse local network devices and see your hdhomerun in there…

You can also enter a url in the following format, replacing X with the IP of the hdhomerun and Y with a channel number:

http://X:5004/auto/vY

For example:

http://192.168.1.23:5004/auto/v2.1


#6

My sync issues cont’d…
I downloaded the VLC app and opened ABC TV Melbourne (HD). Similar sync issues there too.
What does that mean? Is it an Apple problem?
Geez I hate being the meat in the sandwich!


#7

Yes it seems the audio APIs on tvOS are not accounting for sync delay like they are supposed to. The built in video player does, but any custom players using the audio api directly are affected.

I don’t have a HomePod so I guess I need to pick one up to investigate further.


#8

I have submitted a bug report to Apple (rdar://40727741) so hopefully they can shed some light on this issue.


#9

I have the same sync issue here too.


#10

Sync issues… development!
I have accidentally discovered a workaround that fixed my out-of-sync issue.
I pressed and held the play/pause button on the AppleTV remote for a few seconds, released and short-pressed the play/pause button again… sync issue fixed!
Needs to be done every time channels are changed – a little pain for lots of gain.
I hope this one works for all out there with the same issue :wink:


#11

Same issue as others. I never had a problem when it was just a single HomePod, but now that I’ve set up 2 as a stereo pair, audio is definitely delayed and not useable as I had hoped


#12

I have the same issue of delay with my stereo HomePods. It only affects Channels. DirecTV Now, HBO, and Netflix are all fine (audio is properly sync’d). It seems like an Airplay 2 compatibility issue with Channels.


#13

The sync issues have been fixed in v3.2. What version is shown on the Settings tab of the app?


#14

I just tried HomePod audio again today, and am still seeing quite a noticeable delay.

I set audio out to TV and my HomePod pair. Upon tuning a channel on AppleTV (latest v3.2) there is a noticeable delay in starting the video stream, ~3-5 seconds, that isn’t there when audio is on the default TV out. Once the audio/video starts playing the HomePod sound is slightly behind the TV, however the HomePod audio is in sync with the video, while the TV is now slightly ahead.


#15

i thought apples HomePod update today would fix the problem.

I have a problem with audio as well, every time i put my apple TV to sleep, then log back in to watch TV (channels) I need to goto settings on the apple TV deselect the HomePod pair and reselect them again, go back into to channels to watch TV and the sound works, i tried other apps ( apple music, Plex, TBS, History Channel, ESPN Netflix, YouTube…) they work.

any help.?


#16

This is my problem as well with HomePod and airplay2 on Sonos:


#17

Still a problem, looks like there’s either no plan to fix this or they’re just not in a hurry.


#18

What is the problem?


#19

Currently have no Audio from Homepod. I need to deselect and reselct the homepod when using Channels. This is the only app I need to do this procedure for.


#20

Looks like this build, 2018.09.03.1701, has fixed this problem for me. I don’t have the audio issues I have before.