No remote playback on iPhone Xs


#21

I’m going to try using an older iPhone tomorrow at the office and see if it’s sometbing in particular about my DVR setup.


#22

Okay, so more testing.

I installed Channels on an iPad Air 2 that was running iOS 11.4.1 and connected it to my remote DVR. It worked with no issues whatsoever. I then upgraded that iPad to iOS 12 and tried again. It still ran with no issues.

So now I’ve eliminated my DVR as a cause, and it’s squarely so far comes down to the iPhone Xs Max (two of them). Since someone else chimed in on this thread saying it works fine on their Xs, which has the same internals as the Xs Max, maybe it has to do with the screen resolution of the Xs Max. It’s really the only spec difference between the two devices as far as I know.


#23

Something else I just tried. Not sure it helps in any way. I set my internet streaming to “original”, and then played live TV and a recording, and it works just fine. The 35 Mbps up I have helps it actually be watchable, but for diagnostic purposes I figured I’d throw that out there.


#24

I’m also seeing the same thing on my brand new XS. Just submitted diagnostics, although they may not show anything as I submitted them after I force closed them. Anyhow, it doesn’t seem to be a radio issue as I used my iPad to hotspot through my iPhone XS, and the iPad played just fine. Definitely an app issue with the IPhone XS.

When I flip my iPhone back to WiFi all fine.


#25

This is super weird. Thanks for the help on this guys. I personally have a Xs and things are working fine on my device :confused:


#26

You’re welcome.

Very weird, particularly the inconsistency of it working on some people’s Xs and not on others.


#27

Any leads as to what’s going on here? If there’s anything I can do to provide additional data to help, I’m more than happy to.


#28

Same, this continues to not work for the “free” channels DVR app.


#29

I’m getting the exact same behaviour with my XS Max. Remote steaming works fine with my iPad Pro (tethered to the XS Max).


#30

Can you try with the newly released iOS 12.0.1 and v2.2.8 of Channels


#31

Updated to 12.0.1 and verified I’m on Channels 2.2.8, and I still have the same issue.


#32

Still have the same issue as well. Just sent diagnostic logs.


#33

@skoal74 Does it make any difference if you set your Mac DVR to Hardware vs Software transcoding?


#34

I’ve sent out a TestFlight iOS beta build, with an upgrade of video player to see if that has any effect. Let me know if the problem persists (build 10.9.1934).


#35

Just installed the latest beta, and it still occurs. I was able to let it site loading for a while without it locking up the app, so I submitted diagnostics.


#36

Sent out another new beta to try (build 10.9.2137)


#37

I saw the beta a few minutes again and installed. Tried it out, and while it does technically play, the video stutters about every 1 to 1.5 seconds, and is unwatchable. I dropped the quality down to the lowest and it does it no matter what the resolution is set to.


#38

Can you submit diagnostics? What does https://my.channelsdvr.net/speedtest show?


#39

Okay, I’ve submitted my diagnostics. Seems 729p channels didn’t stutter as much as 1080i. Attaching my speed test results.


#40

@stoli412 @skoal74 any luck with the beta?

Another user who was having the same issue and wrote into support said everything is working fine with the beta.