No sound on initial play


#1

I'm running Channels on my Apple TV 4K connecting to a Vizio SB36512-F6 and then onto my TCL Roku TV. It appears that in many cases when I start playing a recording, I hear the background sound but the main audio doesn't play. If I stop the recording and start watching it again, the audio starts fine. The shows indicate that they are DD 5.1 so I suspect that the sound bar is not getting the message on how to decode the audio initially.

While I can connect the sound bar to the TV using HDMI-ARC, doing so doesn't let the sound bar handle Dolby Atmos for Netflix or iTunes.

Anyone seen something like this or know how to correct it?

Thanks.


#2

What is the audio setting set as on the TV? And how is the soundbar connected?

My soundbar is connected with an optical cable, and the TV is set to pass the audio along as raw format, and have no problems with surround issues.

I should also add that my device is connected to the TV via HDMI, and the soundbar is connected to the TV via optical, so the TV is passing theough the audio, rather than the audio coming directly from the device, so that may have some effect.


#3

Apple TV is connected to the sound bar via HDMI. The sound bar is connected via HDMI to the TV (HDMI-ARC). The TV is set to the default format (auto). While I could connect it via optical cable and the problem will likely go away, I lose the advantage of turning on the Apple TV and having my sound bar and TV turn on. I'm also not sure Atmos would pass through optical.

It is a minor inconvenience, but I'm curious as to why it doesn't work initially, but works after I restart it.


#4

I must have missed this in the OP. Perhaps it is related to the "Auto" setting. Although, since you're using ARC, this might not enter the equation. (I guess my understanding of ARC was off; I thought it was used for sending audio received from the other HDMI connections on the TV to audio device connected to the ARC.)


#5

You might try forcing the ATV 4K audio (video and audio>change format “yes”) to 5.1.

Then change it back to Auto, Atmos available (change format “no”) for use with Atmos apps.

No idea if it works, can’t test now as no ATV 4K available until tomorrow.


#6

Thanks for the suggestion. I think you're saying change it and then change it back? Not sure that will do anything. I could leave it in 5.1 as I haven't encountered much Atmos content, yet.


#7

No, leave it on 5.1 as your default.

Only when you have an Atmos source change it to “Auto, Atmos...”.

Then back to 5.1.


#8

I made the change the other day and so far, so good. I don't know if the changing of the format affects anything else, but I'll wait and see.

Thanks!