Not seeing recorded shows on my Nvidia Shield TV Channels App

I have no idea why my Nvidia Shield TV channels DVR is not seeing recorded shows. I am using a windows 10 machine as my Channels server. I am not showing consistency across the platforms of recorded shows. This is Channels on my iPad:

This is what I am seeing on my Nvidia Shield TV:

I can't see any other episodes other than the one shown here no matter how I navigate to this show. I look at windows explorer on my Windows 10 machine and I can find the files for all the new episodes so that isn't it. I have uninstalled Channels from my Nvidia Shield TV, rebooted and reinstalled and they still are not showing up. Why is this happening? Thank you.

Can you submit diagnostics from the SHIELD?

If you can tell me how to do that, sure I can get you the diagnostics for it? Thank you.

Go to Settings > Support > Submit Diagnostics > Other

Ok just did it. Not sure where it uploaded to since I was just given a message to email the support for any other questions.

Thanks. Can you force stop the app and relaunch, then submit diagnostics one more time

Sorry for the delay, I just forced closed and reopened the app and submitted diagnostics other.

Thank you. I'm uploading a new beta APK which may help. Wait about 10 minutes for it to finish uploading here, then can you opt-in on getchannels.com/beta or click Install Beta under Settings > Support and see if there's any improvement?

Thanks for the quick response. Will give it a try. :wink:

That build got lost in the ether, but I'm uploading another one now.

I see Beta version 11.10.202, is that not it? Also,if that is, the shows are still not showing up other than the one episode.

But when I grabbed the beta from the Channels app in the support section 'Update Channels DVR Beta', I upgraded to 11.20.2351, which appears to have fixed it.

1 Like

Wonderful. Can you submit diagnostics on a fresh boot again like last time. I just want to make sure it did everything I expected.

Ok just submitted diagnostics. If you need anything else, let me know. Thanks again for the quick response to fixing this.