Nvidia Shield Can't Access USB for Local Content Import

On initial setup, and thru nightly build 2021.10.13.0312, I selected by USB drive for the DVR path as follows without issue:

After all setup I wanted to import my local content which is also on the USB drive connected to my Nvidia shield, but when I select the plus sign next to movies or tv, I cannot select the USB drive, it is missing from the left side, where I only see Internal Storage:

Any assistance on this would be appreciated.

As a workaround. I tried creating a symlink through adb for my external storage to appear in the internal structure, but root is needed for that, which I don't have on my nvidia shield. Also tried creating a mount point, also needs root.

Hmm does seem like a bug.

You could put the files in the NVIDIA_SHIELD/Imports folder which is scanned automatically.

Thank you for the workaround. That worked for my test.

Similar issue except with mounted Network Drives instead of USB.

BETA Version 2021.10.17.0416 on an NVIDIA Shield Pro.

The Shield allows you to mount a network drive on the Shield and make it accessible to all apps with "Storage" Permission (other devices may support this as well but I can only speak for the Shield). These behave the same as the USB drives in this thread.

The Web UI in the Beta version of the server no longer sees those mounted drives, only recognizing /storage/emulated/0. The mounted drives used to appear in the list on the left by name - then you could browse and select folders.

Those already added do still work, I can refresh them and play videos from them but I can no longer browse to add another folder location for either Movies or TV Shows.

Are they SMB/Samba, NFS or ? network mounts.
What do those paths look like in the web UI?

SMB V2/3, I don't think the Shield even natively supports NFS.

The ones I previously added that still work look like this:

They used to appear in the GUI add dialog list by the first node of the DNS name. (NAS_03), then you could browse into them just like you could the internal storage on the Shield.

I'm sure the devs will address it.
In the mean time if you want to add a MOVIE Import path see this post

For TV Show import path, change paths/movies to paths/tv in the curl command.

Please submit diagnostics from your DVR web UI under Support > Troubleshooting

Submitted with ID: ab783fe8-e818-45ac-9f08-af5bb22c93ed

Are you sure under Android settings you have granted permissions to Channels DVR for storage?

What does it show on

Yes, that is granted - this was working in the PROD version (I previously added two targets and both of them are still accessible, I just cannot add a new one).

0 "2A53-C9A8"
1 "NAS_03" <--- This one is the one I am not longer able to access via the GUI to add a new path.
2 "emulated"
3 "self"

Thanks. Fix coming in next prerelease.

1 Like

Thank you. Will this fix also address the original poster of this thread's inability to access USB based drives (same concept, different target)..