Nvidia Shield on WIFI is freezing with Live TV

Hi All,
Downstairs I use a nvidia 2015 shield on the main TV and it is wired to the network and works with channels app perfectly, no issues to report.

Upstairs I recently purchased the new nvidia shield 2019 (cylinder) version which connects to my unifi wifi network over 5GHZ. It works perfectly with every streaming app e.g. Plex 1080p HD streams for hours on end, with just one exception, you guessed it the channels app.

No matter what channel I'm watching, whether HD or not, the live stream will freeze intermittently, sometimes after a few minutes, sometimes after 30 minutes.

The channel quality is normally above 70%, example below of some hdhomerun stats showing a channel it was constantly freezing on this morning, and everything was 100%. Once channel freezes a simple click of the back button on remote and then play button and everything is back streaming in a couple of seconds.

Virtual Channel|11 Pick
Frequency|666.000 MHz
Program Number|22208
Modulation Lock|t8qam64
Signal Strength|100%
Signal Quality|100%
Symbol Quality|100%
Streaming Rate|1.463 Mbps

I haven't tried wiring the shield to be 100% sure it is caused by it being on WiFi, but I don't believe the Wifi from a network perspective is a problem, maybe from a channel app software perspective it is.

When a TV stream abruptly stops running the hdhomerun logs just show
tuner0 http stream ended (remote closed), which is not a lot to go on. I don't know if there is any channels app logs I can look at to see what might have dropped the stream?

The Unifi WiFi software is showing the shield connection as follows, which seems perfectly fine to me and is rock solid, not dropped off the network in days:
Channel 44 (11ac)
Signal 64% (-65 dBm)
Rx Rate 200 Mbps
Tx Rate 270 Mbps
Power Save Not enabled
Wifi Experience 99% out of 100

I should also mention I've been doing some testing with the hdhomerun android app and it hasn't dropped a stream yet, so again this to me is pointing at a software issue in the channels app when using wifi.

Any thoughts how I can help diagnose the issue from this point forward?


You should test it to see if it happens when wired. Then, if it does work when wired and you insist on have it WiFi, you would know that you should start reconfiguring some settings in your UniFi network. ie: try different channels, move AP, etc.

This is really bad for streaming rate and means 90% of the video packets are being dropped by the wireless network. Compare this to the streaming rate you see when watching from your wired shield.

1 Like

The streaming rate changes depending on what channel I am using it bounces up and down, example below from HD channel on upstairs shield. The Pick channel stats previously posted was SD, so range between 1.2 and 2Mbps I would have said was about right, video packets are not being dropped:

Virtual Channel|105 Channel 5 HD
Frequency|682.000 MHz
Program Number|17728
Modulation Lock|tt8qam256
Signal Strength|100%
Signal Quality|88%
Symbol Quality|100%
Streaming Rate|3.632 Mbps

Will gather some stats from the downstairs shields for comparison, but picture quality between upstairs and downstairs TVs is exactly the same. The picture doesn't stutter upstairs or break up in anyway it just stops.

Interesting, thanks for the additional details.

On the new shield you can try changing Settings > Player > Decoder to Software to see if that helps.

Next time the issue occurs, click Settings > Player > Submit Diagnostics > Video Player

1 Like

I've just sent two submissions within a few mins of each other. I did send another submission bit earlier too, but you can ignore that one. I was watching the channel below for both tests. Decoder was set to software.


Thanks. I'm seeing some out of memory errors. Could be related to the fact that the new tube model only runs 32-bit Android

After the third time of it hanging I then lose the sound and have to kill the channels app to get it back.

Can anything coding wise help with the memory issue, I use the Plex app which streams (direct plays) at much higher bitrates 20+ Mbps and don't have any problems?

I can't be 100% sure but when I bought the shield back in December 2019 I don't remember having any issues initially with channels streaming, so don't know if the problem is related to a fairly recent update. It's certainly happening very often now, and seems worse on some channels than others.

I've submitted some more test results through to you. I've also installed AIDA64, and when the stream stops in channels I switch to AIDA64 and it shows around 840 MB memory free. I'm not aware of any app that could overlay in realtime the memory consumption while streaming within the channels app. Storage wise I have 3162 MB free. Hope this all helps get to the root cause of the problem.

I have the 2019 Tube model Shield setup in my livingroom tv for my mother to use, we just dropped CATV.

She has the tv on all day....for hours.
She has reported that sometimes, after a long time, the channel will freeze and she has to back out to the guide and reload the channel. Only has happened a few times though.

Yesterday, i let a channel stream of 9 hrs straight, no issues. Have tried both with a OTA channel from my HDHR Connect Q, as well as a TVE channel stream.

I doubt its a RAM issue(unless u have other apps on there that are running in the background) and the fact that it is running 32bit OS, only a select few heavy games require 64bit. It may be a Storage Space issue. I used a cheapo spare well used class 10 sd card and it did stutter and just be slow on things, then i put in a new Samsung 64GB Pro Endurance card(was only $22) formatted as internal storage, rinstalled the channles app to make sure it was using the sd card and everything is smooth. (the live tv buffer is stored on the internal storage/sd card, not in RAM.)

The Channels developer has said it's a memory issue on mine. UK streams use different codecs and refresh rates to US, so not an exact like for like comparison. You didn't mention whether you were streaming over WiFi or not?

Also I mentioned above that AIDA64 is reporting free available memory of around 800 MB and free internal storage of 3192 MB, however that is after a stream freezes. What I didn't mention is AIDA64 doesn't report on my SanDisk Extreme Pro micro SD Card which is 64 GB and formatted as internal storage in the shield. I only added the card last week, as I myself thought it might help with this channels issue, but unfortunately it hasn't.

Channels app is currently stored on internal shared storage, I'll move it to my SD card and see if it makes any difference to this problem.

Watch this space!

I left a HD channel playing on my shield this morning and when I came back an hour or so later I noticed it had stopped. Probably too early to say if moving app to SD card has helped or not, but having 2 hours between crashes is a major improvement. However the timing of crashes seen previously is intermittent, so will have to see how it goes.

I managed to work out how to capture logging in real-time to my PC, so I kicked off the same HD channel again and waited for it to fail. It ran from 12:16 GMT until 14:27 before freezing. I've got the full logs between that time and I created a bug report file via adb too.

What is the best way to send these to those concerned, as probably best I don't add as attachment here?

I've also just this second submitted a report via channels app too, better late than never.

Update: I've sent private message to Aman with a link to download the log files.

Perhaps, but he also said it may be cause it is 32bit....which has nothing to do with available or out of memory. 32bit or 64bit OS makes no real world difference on these devices as far as the apps and user experience, far as i have read extensively on.
(I also have run channel app for over 2 hours on an old 32bit Android no name phone with only 1GB ram and only 300MB free space, and it doesn't stop.)

You also state u show it still has 840MB free, so, unless a channels stream uses nearly 1GB of RAM, which i highly doubt, or if there is a memory leak issues somewhere in Channels app, or from another app on your device.....AID64 for me shows, at idle, available memory ~800MB, with a few app I do have paused, not closed out. SO you are in normal range there.

I have the same model with only a few other streaming apps installed, the channels dvr server is on another machine. I also have A Unifi NanoHD...and btw, their firmware is trash of late and it may be some issues there to look at. Many reports of wifi device issues on thier fourms. To wich i am also dealing with. There are a few unifi settings u need to adjust etc. like disable auto optimize etc. And if you recenlty updated the firmware of the ap, that may be the cause.

Hardwired is best idea. Wifi is not reliable even the slightest hiccup of the signal, or interference can cause live stream issues. Try it hardwired and see if you have the same issues.

I had noticed that simply moving the app, does not fully move the app and buffer to the sd card.

I uninstalled the Channels app, deleted app data and cache before, then inserted the sd, format as internal, then re-install channels.

I have the same Shield and have not had any problems. I have a Sandisk Card in it for additional storage ... there is a setting on this shield to tell channels apps what to use for storage I set it to my Sandisk Card (128 GB)

Was stated elsewhere in the forums, but if you turn off tuner sharing in the app, the Channels server has no part in steaming from a HDHR tuner. it direct streams that way. So, whatever bitrate the tuner is getting, is exactly what the channels app is getting. The only way it would be lower, is u have the app set to lower the quality, and thus the sever woudl be force transcoding the stream. (at least that is what I would expect to happen as both Emby and PLex do that when u change that Quality setting)

A thought, is there any dark text in the background when it freezes? like Tuner not responding or Low signal?

I have had both of my shields live stream just freeze when the OTA channel signal had a dropout and it seems channels app can not recover from those unless u back out and restart a tuner stream. I have a couple channels that have signal stats that fluctuate alot depending on the time of day. Sometimes the Symbol Quality drops to 0% for a few secs.
Also, such dropouts, even on channels with very strong signals, can happen if there is a sudden interference between the transmitter tower and your antenna. Or, if you have some other radio operate near by, like HAM or some business band 2 way radio transmitter can cause a quick glitch or drop out of a OTA channel.

5hrs of streaming CBS today,no issues.

Was stated elsewhere in the forums, but if you turn off tuner sharing in the app, the Channels server has no part in steaming from a HDHR tuner.

I don't see any tuner or quality sharing option, I don't subscribe to Channels Plus, therefore don't use DVR, so perhaps that's why no option?.

I've only tried it once this morning upstairs and probably got around 40 minutes of BBC News HD before it stopped.