OTA recording will not play

Recorded the new episode of Family Guy just now.
Trying to playback the recording on my Apple TV and it is just doing that extreme stutter thing, of 1 sec of playback, then stop, then 1sec play etc. Video and audio display fine, but is not watachable.
There is also alot of audio popping noise that continues for several secs even after i back out to eh recording screen.
The video file playback fine on PC.

Submitted diags form the app on the Apple TV.

Edit: Changing the setting Surround Sound to OFF results in the video now mostly playing, but in slow motion like jutter, and a stranger audio echo like thing, still not watchable.
Tried changing the Playback Video and Audio drivers to Default, but no change.
Deinterlacing settings also has no effect.

App: beta 4.28.153
server: 2022.04.28.1311

Edit2: I am seeing this in the server log:
2022/05/01 21:23:40.534665 [DVR] Commercial detection failed for Family Guy S20E17 All About Alana 2022-05-01-2029.mpg with exit status 1

also this if this helps
2022/05/01 21:15:00.049193 [SNR] Statistics for "TV/Family Guy/Family Guy S20E17 All About Alana 2022-05-01-2029.mpg": ss=83%,76%-90% snq=99%,88%-100% seq=99%,0%-100% bps=5456732,0-13006592 pps=468,0-1110

Server diags: 15ba32ab-b00e-4deb-ba1a-efa91b898ad2