Permissions problem for network drive save

So I have a USB drive attached to my router to use as network storage. I can get it mounted in Linux. When I try to set the path to my Channels Recordings to a folder in the mount I receive the following error...

"Error: no write permissions on dvr directory: open /mnt/Channels/DVR/.permcheck: permission denied"

I can mount and navigate the drive no problem from the terminal. I tried granting 777 permissions to the folder and that did nothing.

Is it mounted via Samba/CIFS, or NFS? If the former, you need to specify the permissions, user, and group for the mount at the time you mount it; if the latter, you need to either squash permissions, or make sure you have proper ID maps.

In general, network shares are not the best for DVR storage; a share connected to your router is (in my personal opinion) an even worse option.

However, if you are truly set on this path, please provide more details.

So at this point I have no choice but to try using the router attached drive as it is not powered and my Pi doesn't have the juice to run it and the boot ssd. Anyway, I am mounting the drive using cifs with the following line in my fstab...

// /mnt/dvr cifs credentials=/home//.creds 0 0 is the router IP, usbdrive the name of the shared directrory, and is replaced with my Pi username. Also my .creds file contains just the "username=" and "password=" lines of the user for the shared drive.

Is a powered USB hub an option?

I guess it could be, but I don't have one lying around so I'd need to get one.

You should additionally be using the uid, gid, file_mode, and dir_mode options in addition to the credentials option in your fstab. I think you will find that correctly ascribing these to whichever user Channels runs under will greatly aid you.

1 Like

The moment that I add these in, the mount no longer occurs. I even tried them one at a time, and if I simply put uid=1000 between cifs and credentials, the mount does not take place.

Options in the fstab are comma separated:


If your OS uses Systemd, you can also use mount or automount units, instead of lines in your fstab.

The commas did the trick. In the original I had commas between all the new values like uid and gid, but not between the last one and credentials. Once I got it loaded with the permissions set, I was able to add it to Channels. Good to go now. Thanks for the help.