Playback completely frozen, play/pause, seek or rewind

Playing back a recording today and playback totally froze. Tried pause/and play, still frozen. Seeked back a ways, video still frozen.

I submitted logs after this happened. I tried playing the same recording again and it stopped playing (looks paused but not paused) again in a different spot. Then I killed all of the ATV apps and restarted the ATV, and now the DVR is not showing up in channels. I can get to the DVR over HTTP and see the logs, see several errors about "context deadline exceeded" and "write error: broken pipe".
Now after awhile and checking back, the DVR is showing up again in the app, but the Up Next section is completely empty (says you are caught up.. which doesn't make sense as it was full previously).

Apple TV or Android TV?

Does the dvr web UI load and show all your data?

Apple TV. Did you get the logs? I would have thought it said Apple TV in there.

I was able to get to the DVR over HTTP and everything looked OK there.

I was deleting files right before playing the video when this happened, but I was deleting files as I was out of space. Maybe being out of space caused something to happen on the server to cause this?

Thanks. The Apple TV logs are showing request timeouts trying to access your DVR. Sounds like something is up on your network or with your router

All hardwired, connection between the ATV and NAS is switched, not going through router. Network load was very low during that time and my network equipment shows fully responsive and working. Maybe the NAS itself (QNAP) stops functioning properly when it runs out of disk space? Or the channels app? Not sure if you have played with this condition much.