Playback of recordings randomly skipping forward in chunks

I have submitted diagnostic log 5f50f24c-ec0f-4b8e-b309-db5cfe52efdb I have been having an issue for some time when playing back recordings that the recording randomly jumps ahead a large chunk of time. When it does this I cannot seek backwards on the timeline as the cursor will not move back. It will seek forward. I have flow control disabled. I have turned commercial detection on and off and the problem continues either way. Today I moved my channels server to a completely different computer with a fresh install and already have the same problem tonight. It occurs while watching recordings of in progress shows or completed and processed shows. I have repaired timestamps and index which does not help. I have toggled surround sound on and off. I am using the server remotely and I use a shield pro and multiple fire tv sticks as clients. Server is 64bit on Windows 10. All connections at the server are wired cat 6. All connections for remote clients are also wired. Internet is 100/100 mbps. I would appreciate any help that can be provided.

Sometimes the recording skips ahead 15 minutes sometimes it is only 2 or 3. It is becoming very frustrating. I do not see anything in the logs.

Some more details would help.

  • Which channels?
  • Which sources/tuners?
  • Every recording, or only some?
  • If only some, is there something similar between them all?
  • If only some, is there something else defining about those that have no problems?
  • Are there any pertinent log entries you can share when these issues occur?
  • If they are recordings, are there other abnormalities? (For instance, issues with commercial detection, or the recording not representing the proper amount of time?)

Those are only the few questions that immediately came to mind, but perhaps others might have different questions?

It is happening on hdhr, tve and m3u to basically all recordings. When I first moved the server I had 2 recordings tve on food network that were not effected then it happened to every other recording today. Have had issues on food network in the past. Only drive being used currently is a Samsung Evo ssd. Have tried many. No issues with logs that I see or with time stamps or index on files. Commercial skip detection looks correct and have the issue with commercial detection off and skipping set to manual.

I should note that the recordings are fine. If I exit out and resume watching the parts skipped over do in fact play.

I just played a recording on my phone that is having the issue on the Shield and on my phone it played back without any issue. Phone is a Galaxy Note 20 Ultra with Channels Beta App. Same remote network except phone is on wifi. Both devices set to playback at original quality.

Could there be an issue with the buffer or cache on the shield/fire sticks causing the issue?

It could be the device, but who knows. Again, you're being quite vague. Your OP said every recording and at all times, and now you're stating most times, and on certain devices. Therefore:

  • What are the specific situations that there are no problems?
  • Which devices are having issues?
  • What are the version numbers of all involved components? (DVR, DVR OS, client OS, client app)
  • What is the network path (topology) between the server and the affected clients?
  • You repeatedly state that "recordings", so can it be assumed this is only affecting the playback of recordings? What about live?

Again, you still leave only questions, with no answers given. The community can only use the information you give us to help, but I'd have an easier time changing a lightbulb blindfolded in my neighbor's house down the street (whom I've never met) than giving any relevant assistance here with what is known so far.

Live TV is fine unless watching an ongoing recording of a live program from the start.

Network is not the issue. It is remote playback from a 100/100 wired connection and everything is wired gigabit cat 6 on both ends. Other devices ony client network are not having the issue. At present time the problem seems limited to the shield pro. It is running the latest beta but has had the problem for about 6 months or more.

Server is a clean install of 2021.05.26.1807. However the shield has had the issue from a different PC updated daily to the latest beta for 6 months or more. The same issue on the fire sticks 4k was not present last night. Server is
12 cores / Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz. Server had amd video card. Old server had Nvidia card. Problem remained on every combination of both hardware and software encode/decode on either end.

After moving the server to a new computer the shield worked fine on 2 30 minute recordings as referenced above. It then began skipping on every other recording. Those recordings played back no issue on all other network devices. The connection from shield to server is 100 mbps as it should be. Diag logs were submitted to the admins as referenced above.

The issue seems to be with Shield memory as after it skips I can only seek forward in a recording and not backward. It is as if it has dropped the buffer and skipped to what is being fed immediately.

It sounds like there is something wrong with that particular Shield. I have three of them that get used every day and have not experienced the issues described.

I kind of feel that way as well. I do have access to a shield at another location I can try as well to see if that has the same issue. I Uninstaller and reinstalled the app on the shield which did not help. The only concern is that the issue use to happen on my fire sticks. However, at least last night, the same recordings having the issue on the shield played fine on a fire stick and my phone. I was hoping maybe some glitch was addressed on the fire stick but not the shield. Does anyone know of a memory issue or buffer issue on the shield? What is really puzzling to me is that when I start a recording I can seek forward and back no issue but after it skips it will not seek back. The curser simply will not move backward like the shield has a brand new file that starts at that point and goes forward and the rest of the file was flushed from memory.

I would be curious if any of the admins see anything in the debug logs.

Update: to add another piece to this I was just searching Google specific to the issue on the Shield and not specific to Channels. I found a thread regarding the HDHR app that freezes and will not properly ff and the solution is to enable ac3 pass-through. I do have surround turned off here which did not help and the issue persists with surround off and on. I then stumbled across the following thread which seems to be a very similar issue happening with recordings on plex on the shield. No solution. Before anyone asks I do not believe there is an issue with my remote as I have used 2 different ones and again it will not skip back. hxxps://amp.reddit.com/r/PleX/comments/ilxag2/issues_with_skip_forward/

The diagnostics from your SHIELD did not show any player activity. The logs only include recent messages.

So where do I get a log from that might show something?

Could it be possible that an audio dropout on the Nakamachi receiver/soundbar between the shield and TV could cause the skip? I am not hearing a dropout when it skips but could it be triggering a resysnc before it plays bypassing the current buffer?

Did you submit the diagnostics after experiencing the skip?

I don't think the app or shield knows when the receiver/soundbar has an issue.

I’m sure you’ve already checked this.. but how much free space is there on the shield? It sounds like something could be Messing with the storage Channels needs to run. Could there be some kind of optimization or other software that has been installed?

I believe I have figured it out. At least for now recordings that were not working yesterday are now. I did have 3gb free on shield pro but deleted some unused apps anyway and cleared the cache. In channels I enabled hdhr legacy support. Not sure of that does anything on tve recordings. Did a full power down of shield and left it unplugged for 5 minutes. What actually seemed to be the final setting to fix it was under apps on the shield menu and special permissions power saving optimization was enabled for Channels DVR. I disabled it. It is now working. Fingers crossed. I will report back with an update. Odd setting. Thank you everyone for the tips.

Eric

Since you were using external storage with Channels, it looks like the Shield might have been powering down your external storage, causing other unforeseen issues.

1 Like

This only applies to actual HDHR sources, so it will have no impact one TVE sources. FYI.

I am not using external storage. My server is a windows 10 core i7 with all ssd's. I have no external hdd on Shield. After playing a single 1 hour recording on shield in channels the Shield Cache jumped up from cleared to 3.6gb. With the limited amount of storage NVIDA is so kind to provide this could certainly be an issue. Any idea why channels would be filling the Cache and not clearing it?

You realize that all of the cache, buffer, and local storage happens on the client, yes? It has nothing to do with your server?

Update. Just tested on another recording, the Shield Cache is filling up from Channels and is not clearing when the recording is stopped or the app is properly closed. Is there a fix for this short of manually clearing after watching every recording? On live TV it is not filling the Cache at all after the stream is stopped.

Yes I realize where things are cached. Racameron mentioned something about external storage. I never said I used external storage so I presumed he was referring to the server. The energy efficiency power optimization setting on Android tv has nothing to do with the USB ports its under storage-apps-special permissions.

I'm having a similar issue here. My setup is different. Server is on Ubuntu 20.04. storage is 3 wd Nas drives (not the smr) configured as zfs. Client is firetv and fire stick. The work around is to either exit the play back or restart the fire devices. Streaming over the internet.