Playing a recording black screen /w audio

This never occurred even a single time until within the last month or so. When trying to play a recording, I'll get a black screen with audio. Sometimes exiting and restarting the recording resolves it, sometimes I have to force stop the app on my Shield and restart it and that resolves it.

It's not all the time, but it has occurred enough lately to be a nuissance.

Need the version number shown in the app, the Android device name and OS version, and diagnostics from the app sent after the issue.

Okay, sure.

The black screen with audio when trying to play "CBS Sunday Morning" happened again this morning. The second time I tried to play it, it played fine.

I submitted diagnostics for this right after it happened @ 10:12am on 7/5.

Channels 2.1.25
Nvidia Shield P2897
Version 9

Been having the same problem on nvidia shield pro for last few months. Usually I just restart the show a few times and it plays.
I think I found this topic the first time it happened but it keeps happening.

Sent logs, but it happened maybe an hour ago?

Actually reproing it intentionally is tough. Initially I thought it was when deleting a show that's currently recording and switching to another before the delete had completed (based on the thumbnail of the deleted show remaining visible after it had been "deleted"), but just tried it and couldn't get it to happen.

Channels DVR Server 2020.08.19.2205
Channels Client 2.1.25
Nvidia Shield P2897
(kernel: 4.9.140-tegra-g711c85019969)

I'm seeing this with live TV also now periodically.

Ok it just did it again 30 seconds ago. Submitted logs.