Provider - Cox

I did contact COX and the problem was on their end. I am able to 100% connect and view live content on NBC.COM/LIVE. My problem now lies with adding COX as a source... I am stuck on channel DISCOVERY 68/186.

Try refreshing the page. Does the Log tab show or stuck there too?

Multiple tries now stuck here on 71/186 HGTV

2019/10/19 16:37:21 [TVE] Channel scan 71/186 HGTV successful
2019/10/19 16:37:33 [TVE] action=set_cookies domains=1
2019/10/19 16:37:33 [TVE] action=navigate url=
2019/10/19 16:37:33 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:34 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:35 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:35 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:35 [TVE] action=auth_domain
2019/10/19 16:37:35 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:36 [TVE] action=request type=Document method=GET url=
2019/10/19 16:37:36 [TVE] action=wait_for_page
2019/10/19 16:37:45 [TVE] action=page_ready
2019/10/19 16:37:45 [TVE] action=wait_for_page done=true reason=page_ready
2019/10/19 16:37:46 [TVE] action=fill_form u=vegasmerricksm

If you leave it for awhile, does it eventually finish?
If so, you can then click the pencil icon to edit your TVE channels and click the edit button on the upper right, then rescan each channel with errors one at a time. You may have to wait a couple minutes between each one.

UPDATE!!! Rebooted NVIDIA Shield, HDHomerun and Router and all the channels finally loaded. Thanks for everyone's help and support.

My Cox channels just did the same thing... all of a sudden they were unauthorized, so I deleted and re-added Cox as a source and half my channels disappeared the yesterday. I have deleted and re-added my Cox source today and still nothing changed! Don't know if @vegasmerricks is also in Las Vegas (because of the name) but maybe it is a Vegas thing? I rebooted my HDHomerun and nothing changed after re-adding!

Does it work on

CNBC doesn't work for me with Cox. It just times out.

I just added My Cox subscription and also live in Las Vegas. I also only get 48 Channels and can't get the main channels as they say not authorized. I can login with with no problem. I also am watching the channels (FNC and NBCSN for example) on my apps on apple tv.
Any suggestions?

Hmm strange. Can you watch FNC on ?

Please email [email protected] with the full logs from the Log tab starting at when you started setting up the DVR with your Cox login.

Yes. I just tried (i usually use and it made me sign in and verify location, then worked just fine. I just tried to add TVE Cox to my channels DVR and same result. I am emailing the log to you now.

Try with v2019.10.24.0015

Yeah does work for me. I updated to latest version and rescanned Cox but still only getting 45 channels!

Email us with the logs from removing and readding the source

Ok it worked when I deleted the Cox source and then added it again! I guess that needed to happen instead of "Rescan all Channels." Glad it is fixed!

1 Like

I am not sure if I should comment on this thread or start a new one, but ultimately decided to start here as it is directly related to this.

I am trying to set up a new server (Version 2021.01.06.0017... I am testing to see if this is a solution for my household during the free trial period) and I am using my Cox login for TV Everywhere. However, it is only finding 63 channels and they are all relatively irrelevant channels. None of the main cable channels are showing up. They all show up as not authorized. However, I am able to log into them using the individual apps or websites (for example, Disney Now,,, etc). I will be using a Pi4 for the permanent solution if I am able to get this to work and convince the family that this is the solution for us.

I submitted a log to the support email address also. Below is the start of the log I submitted to support..

2021/01/05 23:25:07.066936 [TVE] Auth starting for Cox as ------ (redacted)
2021/01/05 23:25:07.066936 [TVE] action=auth mvpd=Cox requestor=nbcentertainment
2021/01/05 23:25:07.319232 [TVE] action=error_response type=Other
2021/01/05 23:25:07.344280 [TVE] action=navigate
23:25:07.345277 [TVE] action=request type=Document
method=GET url=
23:25:10.032433 [TVE] action=request type=Document
method=GET url=
23:25:10.032433 [TVE] action=auth_domain
2021/01/05 23:25:10.279773 [TVE] action=request type=Document
method=GET url=
2021/01/05 23:25:16.173142 [TVE] action=wait_for_page
2021/01/05 23:25:16.441194 [TVE] action=request type=Document
method=POST url=
23:25:16.624362 [TVE] action=request type=Document
method=GET url=
23:25:16.624362 [TVE] action=authed
2021/01/05 23:25:16.625404 [TVE] action=wait_for_page done=true
2021/01/05 23:25:16.626352 [TVE] action=cookies num_domains=1 num_cookies=7
2021/01/05 23:25:16.628348 [TVE] action=error_response type=Document
2021/01/05 23:25:17.553480 [TVE] [ERR] failed to discover local NBC
station: notAuthorized
2021/01/05 23:25:19.675858 [TVE] Channel scan starting for 209 channels on Cox
2021/01/05 23:25:20.130727 [TVE] Channel scan 1/209 ABC failed: notAuthorized

You're trying to use the Cox login from another service address and its auto-logging into the Cox account associated with the internet service. There is no way to work around this afaik. Other providers like Comcast offer a way to disable auto-authentication

You are correct, I do have two accounts. One is for this location that is internet only (my server is here) and one for my home (internet and TV). I am specifying the account credentials of the correct account. How do I get this to work then? Is it even possible? If I take this to the other location and authorize it there and bring the computer back to the internet only location, will it continue to work?

It will work for a few weeks maybe before breaking again. There's no way to make this work other than hosting at the location with the TV service.

I figured out how to get it working, at least temporarily. The problem is that the DVR is ignoring the credentials I provided (TV/Internet account) and using the credentials of the internet only account (like you said). I got around this by turning my phone into a hotspot using the cellular network, connecting my computer to this hotspot and then adding the source in the DVR. I then put the computer back on my regular network. While this is not ideal, it will let me do some testing. Thank you for your help last night!

1 Like