Raspberry Pi Image: TVE client timeout issues

I cannot seem to get directv to authorize on TVE. I get the following error message:

Post "https://sp.auth.adobe.com/adobe-services/session": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

I'm using the latest raspberry pi build. Both the operating system and server are completely up to date. I even tried youtubetv and that gave similar errors. Tried a bunch of searching on here. Help!

Log attached below (I've removed the email address):

2020/11/13 22:41:26.215002 [TRS] DNS: OK: Resolved host via system DNS
2020/11/13 22:41:31.215378 [TRS] Cloud Reachable: ERROR: Could not connect to community.getchannels.com: Timeout after 5 seconds
2020/11/13 22:41:31.371614 [TRS] Local Time: OK: Local clock is accurate
2020/11/13 22:41:31.371794 [TRS] Remote Access: OK: Remote access not configured
2020/11/13 22:41:31.372772 [TRS] Disk Permissions: OK
2020/11/13 22:42:59.861684 [TVE] Auth starting for DTV as *****@gmail.com
2020/11/13 22:42:59.861906 [TVE] action=auth mvpd=DTV requestor=nbcentertainment
2020/11/13 22:43:00.381999 [TVE] action=navigate url=https://sp.auth.adobe.com/adobe-services/authenticate/saml?noflash=true&mso_id=DTV&requestor_id=nbcentertainment&no_iframe=true&domain_name=adobe.com&redirect_url=https%3A%2F%2Fsp.auth.adobe.com%2Fadobe-services%2FcompletePassiveAuthentication
2020/11/13 22:43:00.384879 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/authenticate/saml
2020/11/13 22:43:05.608918 [TVE] action=wait_for_page
2020/11/13 22:43:05.651690 [TVE] action=request type=Document method=POST url=https://idp.dtvce.com/dtv-idp-authn/authn/v2
2020/11/13 22:43:05.651756 [TVE] action=auth_domain domain=idp.dtvce.com
2020/11/13 22:43:10.957583 [TVE] action=request type=Document method=GET url=https://idp.dtvce.com/entitlementlogin/login.do
2020/11/13 22:43:16.356337 [TVE] action=page_ready
2020/11/13 22:43:16.356488 [TVE] action=wait_for_page done=true reason=page_ready
2020/11/13 22:43:16.356547 [TVE] action=fill_form u=*****@gmail.com
2020/11/13 22:43:16.379578 [TVE] action=request type=Document method=POST url=https://as.dtvce.com/idp/login
2020/11/13 22:43:16.383224 [TVE] action=wait_for_auth
2020/11/13 22:43:22.321724 [TVE] action=request type=Document method=POST url=https://sp.auth.adobe.com/sp/saml/SAMLAssertionConsumer
2020/11/13 22:43:22.397149 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/completePassiveAuthentication
2020/11/13 22:43:22.397265 [TVE] action=authed
2020/11/13 22:43:22.400742 [TVE] action=cookies num_domains=2 num_cookies=9
2020/11/13 22:43:22.404076 [TVE] action=error_response type=Document error=net::ERR_ABORTED
2020/11/13 22:43:32.455297 [TVE] Auth failed for DTV: Post "https://sp.auth.adobe.com/adobe-services/session": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Please click Support > Submit Diagnostics

It looks like some kind of network or dns issue. Do you have any adblocking firewalls on your network?

That was my first thought. I just have a netgear r6700v2 router. Standard settings. Nothing fancy. I am plugged into an unmanaged switch however but that shouldn't affect things.

Just scrubbed through the router settings and don't see anything that pops out at me.

Edit: logs submitted as ( 80241d74-b6a2-486a-8fac-8dbb33a081c7)

I did turn my router upnp settings off.

Spent a little time troubleshooting this morning. I installed the DVR software on my windows machine and ran through the setup. DTV pulled the channels in just fine and they all play. My windows machine is connected to the same router that the Pi is connected to. Something with the Pi configuration is definitely amiss. I know the Pi is reaching the DTV server because if I enter the wrong password it comes back with the image of the wrong password.

Any thoughts as to what's going on? It appears that I'm running bootloader 694e118a Oct 28 2020. Not sure if that could be the issue...

I'm adding more diagnostics in v2020.11.19.0545

Please update and submit again from that build.

The Oct 28 bootloader is the correct one.

Just wondering if you had a chance to submit diagnostics. Would love to get to the bottom of whatever is going on here.

Will get around to it today. Was running the dvr service on my PC in the meantime. Need to migrate some data to an internal drive so I can image my external drive.


I redownloaded the raspberry pi image from the website. I tried to update both the operating system and server (pressing and holding update) and there were no new updates. I tried logging into DTV TVE and it failed. Logs submitted above. I can confirm that I have been running this with my windows PC for about a week now with no hiccups.