Recordings not Transcoding for remote playback

Is anyone else having issues with transcoding video when watching recordings remotely.

This started over the week or so.

When I try to play certain recordings remotely the tv meta data and film timeline appears on screen like usual when starting a transcode, but films never starts just continues to load. Other recordings made around the same time do transcode.

Meanwhile the channels dvr server settings activity shows

Watching recording Fatal Attraction (1987) 2021-03-27-2219.mpg from xxx.xxx.xxx.xxx (Transcoder Ready).

And log shows

2021/03/28 11:46:57.692611 [HLS] Error while serving segment 1 for file1538-8910e3a28b0e: EOF
2021/03/28 11:47:14.516630 [HLS] Error while serving segment 0 for file1538-8910e3a28b0e: EOF

Current hardware setup.

Channels dvr server running on synology DS1520+ at the time of post latest pre release 2021.03.27.1729

Remote client is Apple TV 4K running 2021 (3.26.2329)

TV Source is Kathrein Exip 418 SAT>IP using an M3U

So far I have managed to narrow the channels down to BBC1 and BBC2 which are associated with Chanel 101 and 102 on my m3u.

Subsequently on further testing these channels do transcode if watching live.

If I change the transcoder to the older version on the dvr server settings it does remotely transcode recordings.

This was not the case a few weeks ago, Is this a bug?

I would recommend submitting diagnostics from the DVR server if you haven’t already.

Try clearing the cache under Transcoder? Is it set to hardware or software?

The first thing I did was clear the transcoding cache!

The problem only occurred with my channel 101 and 102. Another user @JohnMcClane that I introduced to channels using the same set up as me with SATIP with an identical M3U as me is having the same issue while remote transcoding.

Having changed to old transcoder issue has been resolved but it was not an issue before ie 2 weeks ago using the new transcoding technology.

We are both using synology NAS running channels dvr server. Everything is hardware transcode as it is supported by intel celeron J4125.

Any thoughts?

I did submit logs earlier!

Thanks for your support

Baker

Could you email [email protected] with a small recording which causes the issue.

No probs! I’ll send it over!

Hi tmm1

I have just responded with an email with a link to my NAS to a 36mb file recorded on the channel in question.

This file does not play on my remote client using the current transcoder

It does play if I select older transcoder

Baker

@tmm1 @bakerboy

As mentioned above I have been having the same issues - first noticed this a week ago today while playing a recorded programme on remote server. A message appeared on the Playback screen on Apple IOS client and could not play any of the transcoded content. I can’t remember what exactly the error message said as I’m not using remote a lot but it certainly would not even attempt to play the DVR recording.

On a side note is there any way of recording a specific part of a recording through the app as I only have the option of recording the whole lot and changing the finish point? I’m not sure how to record a 10 second clip of a programme.

Keep up the excellent work !!

It looks like the pids= parameter in the SAT>IP url for BBC has become out of date and is missing some of the stream information required. We're working on a fix for the transcoder, but it would be best if you update your M3U to match the new broadcast.

1 Like

Thanks for the heads up. I have just tried again with pre-release 2356 and same issue so looks like the PIDS needs to be updated for BBC in the URL. Can you confirm if the fix has been ironed out on the channels end yet and its just the PIDS to update?

@bakerboy

The latest DVR pre-release should be able to handle these issues, but it still would be better to filter the PIDs before it reaches the DVR.

Reviewing Astra 28.2 BBC channels (a quick look over) doesn't seem to have had any recent PID changes? Certainly not since the m3u list I provided @bakerboy a while back.

Can I ask why a PID problem would cause an already recorded TV episode or film to fail a transcoded stream?

If a scheduled recording completes ok, video & audio are available with no issues with playback on local network playback, why would tuning / m3u list config be the problem?

Parts of the stream are missing and have not been recorded. This metadata is used by the transcoder. We fixed the bug originally reported so if it's still not working please share the new error shown in the logs and diagnostics.

1 Like

Ahh ok.

For anyone who needs it... please see download link below. An updated list of video channels (FTA) from Astra 28.2 including correct PIDs as of 06/04/2021.

The m3u file will require downloading & opening in an editor such as Notepad. "IP SERVER ADDRESS" within the file will need to be replaced with YOUR SAT>IP server IP address... i.e. 192.168.0.99.

Once the IP address of your SAT>IP server has been added, save the file & load into Channels DVR.

Please note - This file is a FULL list of FTA channels. You will have to delete any duplicates / unwanted channels - This can be done either within Notepad, or via the Channels DVR server settings - "sources" - "Manage Lineup".

Thanks.

28.2E Channels

Just tried watching DVR recordings on pre-release 2238 and now the videos will attempt to play but its jittery on and off throughout the playback.

Its an improvement over the original issue as my recordings would not play at all before the update.

Log file sent

I don't know whether this issue that im having (which ive just discovered this morning) is related or not...

My Huawei t5 media pad will not play any HD content (live & recorded tv) smoothly. All SD stuff seems to work ok... however using my Huawei smart phone all HD content plays back ok without issue?

I've done a few basic things - Confirmed the DVR server is up to date, reset my server PC and home network, checked settings in the DVR server, uninstalled & re-installed the Channels app on my T5 media pad... but still having the same issue. This only seems to be related to my T5 media pad using the Channels DVR app - I tried HD live tv playback on my T5 media pad using the HDHomeRun app, and everything plays ok. Not sure what's going on?

Check the client decoder settings. It’s possible it doesn’t have enough horsepower to decode and display the video smoothly. Changing to a different decoder type might help.

How do I change the decoder type?

In the client settings, under playback, advanced.