Recordings Start Playing, Then Immediatly Bails-Out, Using Cellular Connection


#1

(I posted this under DVR Troubleshooting because changing a setting on the DVR seems to affect it.)

Playing with some things I just tried to watch a recording on my iPhone over a cellular connection. I hit "Watch Now," get the spinner, the first frame (I assume) shows up, the spinner goes away, there's a brief snatch of sound, and the app bails out back to the "Up Next" and "Recently Recorded" screen. This happens with every single recording.

Live TV works fine. Recordings work fine when locally connected.

Have been using software transcoding so I can get the subtitles. Switched to hardware transcoding. Problem went away. Switched back to software transcoding. Problem stayed away, but... what's this? No subtitles! Hmmm... Picked another program. Bailing out problem returned. Went back to the one I tried with hardware transcoding. Played, but no subtitles.

Colour me thoroughly confused.


#2

Strange.

Can you submit diagnostics from the app after it bails out.


#3

Will do.


#4

Done!

Oddly: At first it was playing everything this morning. Then I found something over which it would stumble.


#6

Do you have both the regular Channels app as well as the Channels Beta app?

If so, and the problem occurs in the regular Channels app... try opening the Beta app and disabling automatic commercial skip. Then go back to the regular non-Beta app and try again.


#7

Thanks for the suggestion, but I think I'll just wait for an answer/resolution from the dev team.


#8

I might be running into this same issue now... see On AppleTV only (not iPhone), remote playback of recordings is broken when using software transcoding on DVR server

I found that using hardware transcoding, and using a low enough bitrate to force transcoding, seems to mitigate it (albeit at a huge loss of picture quality)

EDIT: actually might not be the same issue. I'm pretty sure the issue I'm experiencing only affects tvOS, not iPhone.