Remote: live works, recordings fail


#1

I can watch live shows on my ipad in the hotel fine, but watching dvr recordings seems to fail. I am using an older laptop as my dvr server using ubuntu, so i thought maybe it was underpowered, so i dropped the resolution and played with blend and linear transcoding to no avail.

. OS
LENOVO 43192RU
Linux Ubuntu
18.04 (kernel: 4.15.0-51-generic)

CPU
8 cores / Intel(R) Core(TM) i7 CPU Q 820 @ 1.73GHz
load averages: 2.12 2.01 1.74

RAM
7.72 GB
72.7% free

Overall, I am really impressed with the app - Great Job!


#2

Are there errors shown in the dvr web UI Logs tab


#3

I wonder if it was just a bad connection, or if my server is underpowered? This morning it is working better - i am not sure what I did - I think i increased the resolution thinking that its closer to the original format and the transcoder wouldn't have to work so hard.

2019/07/02 07:41:02 [HLS] Starting transcoder for file2062-be0665eedb4d at 0s from 50.239.174.98 (encoder=libx264, resolution=1080, deinterlacer=blend, bitrate=10000)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 2)
[libx264 @ 0x237dac0] MB rate (118800000) > level limit (522240)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 2 times
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 2 times
[mpeg2video @ 0x235e9c0] ac-tex damaged at 26 29
[mpeg2video @ 0x235e9c0] Warning MVs not available
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 1 times
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 2)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 9 times

.....

[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Error while decoding stream #0:2: Error number -16976906 occurred
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)

....
[mpeg2video @ 0x235e9c0] skip with previntra
[mpeg2video @ 0x235e9c0] Warning MVs not available
....
mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
[mpeg2video @ 0x235e9c0] mb incr damaged
[mpeg2video @ 0x235e9c0] Warning MVs not available
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 1 times
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 2 times
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 2)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 1 times
[mpeg2video @ 0x235e9c0] mb incr damaged
[mpeg2video @ 0x235e9c0] Warning MVs not available
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Error while decoding stream #0:2: Error number -16976906 occurred
....
Error while decoding stream #0:1: Error number -16976906 occurred
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 2)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
Last message repeated 1 times
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 2)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 1)
[mpegts @ 0x2356300] Dropped corrupted packet (stream = 0)
2019/07/02 07:48:21 [HLS] Stopping transcoder session file2062-be0665eedb4d @ 7m16.938667s


#4

Trying to play a stream in the channels app causes an immediate abort, but playing in the web browser allows for some video playing with long pauses. The transcoder looks like it is at 0.3 to 0.5x - does this mean the laptop is underpowered?


#5

This chip is pre-quicksync(2009), and that Nvidia chip in that laptop isn’t any help either. It looks like you CPU is very busy.

I’d say, yes, it’s underpowered. You need something newer than 2011.


#6

Is there a way to bypass transcoding and send native images at a slower frame rate?


#7

I don’t believe so