Remote login with different port no longer possible

Before the recent changes I was able to login with a different port by copying the auth "button" link and manually changing the port, now I can't get to the auth "button" because the page loads to a "server not found" message.


help please, I have no way of logging in a new apple tv withing being able to manually change the port (which has been possible up until now).

Will take a look

1 Like

Same for me too.

OK. I've fixed this.

We made some changes to remote auth to be a little more friendly with errors. We check to see if we can actually connect to your server first before we just allow you to auth. This manages some issues ahead of time. Because of that, we were hard coding 8089 in. Now you can pass in a custom port.

To use custom ports now, you need to add on &port=8800 or whatever your port is, to the remote auth URL. So when you land on the auth page, just edit the url and reload it. It will pass the custom port in and use it.

This didn't work for me, the error now shows the correct port in the error message though.

Would it be possible to add an external port option to the DVR server side settings the way Plex does and have it passed on the the auth server as a variable that defaults to 8089 unless port is manually entered?


Would it be possible to add an external port option to the DVR server side settings

It is not at the moment.

Weird, I swore that would have fixed it. I'll check it out again later tonight.

1 Like

Any progress?

Sorry, I don't want to excuse anything, but I had a family emergency happen this week. That's why I sort of ghosted on this.

I'm going to give this another go tonight. Thanks!

Any luck? I tried again last night but had the same results.

If you're still dealing with family issues I apologize, but I need to resolve this in order to track down an issue affecting my parents ability to play back recordings. They have their own DVR that runs on a different port and without being able to authorize a device I have no way of troubleshooting.

I also have another Apple Tv I need to login but that is less important at the moment.

It looks like we figured it out. There was an issue in the DVR server that would prevent it from responding in a way that our auth server needed to verify that it was available.

We’ve built a new prerelease of the DVR server with the fix. Go ahead and update to that and try it.

Hi there
I've updated my DVR to 2019.07.15.2123 however I can't get the authorisation page to change the port in the URL for IOS.

My router has 8089 reserved so I have to use another which used to work ok. I can still access the Web UI with my port in the URL so no big deal but please advise steps if known.


Did you try this:

Hi, I don’t get the opportunity to change the port in the URL.image

The URL is shown at the top where it says "". Click that and edit it.

I used to be able to do that but not now.
How do I get the port in the URL to change it, please?:

Go to the end and type &port=XXXX using whatever port you want to use. Then hit enter.

Ahh got it, thanks and working well. Append instead of amend now!

1 Like