Remote streaming constantly buffering

Lately, when streaming remotely using an Apple TV, the broadcasts will buffer frequently. Looking at the logs, I see tons of lines (with new ones being created) indicating:

2022/11/18 10:08:52.009677 [HLS] ffmpeg: ch2.1-dANY-80fcf5bff44e-1-h264-aac-copy--7488-256-720-0-0---false-false-0.01-0: [hls @ 0x2dbac180] Non-monotonous DTS in output stream 0:0; previous: 15965317, current: 0; changing to 15965318. This may result in incorrect timestamps in the output file.

OTA channel 2.1 in this case, but it happens with any channel, even TVE. Is this something I can fix on my end, or is a server update potentially required? Currently running version 2022.11.18.1439 of the server, and version 2022.0601.2221 of the OS.

I've had it occasionally buffer when streaming remotely before, but nothing as disruptive as this.

I just submitted logs, if that helps:

692da82d-7436-411d-96c8-cda832dde9c7

I've installed several pre-release updates since this post, but unfortunately the issue persists. Log is indicating the same error that I originally posted.

I was hoping the ARM transcoding update would help, but alas :frowning:

If you watch in the browser what does it say underneath the video for FPS and speed?

When watching via a browser (remotely):

Transcoder Running at 7mbps: 1m10s @ 0.89x (52.80fps)

I used to have the Playback Quality set at the max 1080p @ 10mbps setting, and bumped it down to 8 when the buffering became practically unbearable, but this hasn't helped.

Every time I start a remote steam (primarily via my Apple TV), the log gets overloaded with "Non-monotonous DTS in output stream" errors. Local streaming works without a problem, both OTA channels & Custom Channels. It's just Remote DVR that's having this issue.

Seems like you're trying to watch a 60fps channel but the dvr can only do 52fps, so it lags behind and causes buffering.

The log messages are not an issue.

Just wanted to loop back to report that this has been resolved! :white_check_mark:

My Internet Streaming Quality was set to 8Mbps on one Apple TV, and to 6Mbps on another. I'm quite sure I preemptively set these values myself when originally setting this up, but it was working until now :man_shrugging:

Regardless, setting the Internet Streaming Quality to Original resolved the buffering. Seems that's the best option when using the Pi as the DVR Server, at least in my case. Otherwise, it struggled with transcoding. I suspect Internet speed would play a role here as well, but that wasn't my bottleneck.

Where is this setting to go to "original"? I can't find it in the web admin.

Its on the client UI