Restore From Backup

I reinstalled Mac Catalina but am missing my recordings and passes. I can see them on the drive but they don't appear in Channels. I unchecked the DVR option and tried to browse to the database directory under restore from backup but get a spinning icon like it can't find the database.

Any ideas how to fix this?

The log is giving me a panic recovered error message:

2020/11/15 19:04:02 [Recovery] 2020/11/15 - 19:04:02 panic recovered:
invalid page type: 0: 0[email protected]/cursor.go:250 (0x43808d2)[email protected]/cursor.go:159 (0x437feec)[email protected]/bucket.go:105 (0x437be84)[email protected]/tx.go:101 (0x4cbf510) (0x4cbf4be)[email protected]/db.go:725 (0x438378d) (0x4cb8afe) (0x4e1a10b)[email protected]/context.go:147 (0x459fc6a) (0x4dcbd72)[email protected]/context.go:147 (0x459fc6a) (0x4dcae2e)[email protected]/context.go:147 (0x459fc6a)[email protected]/recovery.go:83 (0x45b2dbf)[email protected]/context.go:147 (0x459fc6a)[email protected]/logger.go:241 (0x45b1ed0)[email protected]/context.go:147 (0x459fc6a)[email protected]/sessions.go:65 (0x4cfa372)[email protected]/context.go:147 (0x459fc6a)[email protected]/gzip.go:47 (0x4cf36b0)[email protected]/context.go:147 (0x459fc6a) (0x4de8e1d)[email protected]/context.go:147 (0x459fc6a)[email protected]/gin.go:403 (0x45a95b2)[email protected]/gin.go:364 (0x45a8cbc)
net/http/server.go:2836 (0x4324282)
net/http/server.go:1924 (0x431fbeb)
runtime/asm_amd64.s:1373 (0x406c3e0)

There appear to be some broken/corrupted backups in your directory. Try making a new folder called Old underneath Database, move all the old backup folders under there instead of the most recent one you want to use, then attempt the restore again.

I tried making the old directory. It is telling me that No backups found in this directory.

I'm asking you to move the old backups away, then restore from the original Database directory which should only have one backup-XXX folder inside it.

Ok, thank you. I see the recordings now!