Scrypted gets Ring doorbell and security camera feeds into Channels' guide too

Here's a tip that will be of interest to Ring camera users. I set up Scrypted on a Raspberry Pi to connect my Ring cameras to HomeKit Secure Video. It works very well:

One feature I discovered afterwards, is that it also let me connect these video feeds to Channels DVR's guide. Once I set the "Rebroadcast Container" to RTSP, a Rebroadcast URL was presented. I copied that, substituting "localhost" with the IP address of the Pi. I then used that URL when setting each up as a Custom Channel in Channels DVR.

tvOS 15.4 now lets you monitor any HomeKit video feed via picture-in-picture but this allows you to integrate the camera feeds individually into Channels' guide interface too, just like other webcams.


Anyone get this running on Docker in Linux... it seems to download and extract everything fine for me but then when I go to pull the image it it denies permission

I don’t run Linux and can’t help with that but have seen @koush, the developer, very active in his Scrypted channel on discord. I’d bet I’d you asked there you’d get a quick answer.

1 Like

Just for anyone searching and finds this - there is a docker container for Scrypted.

1 Like

Home Assistant add-on:

New documentation page:

Could you explain a bit more about this? I have scrypted running, the ring plug-in installed and I can view my ring cameras in the scrypted web UI. I don't see the "Rebroadcast Container" setting. I see under settings>streams a RTSP rebroadcast URL but opening this stream in VLC (using the ip of the scrypted host instead of locahost) does not work.

Yeah, the RTSP streams didn't work for me in VLC either, but they do work in Channels. Not the SIP ones, but the WebRTC ones. Looks like Scrypted's renamed this section recently:

I tried the WebRTC URL but I get a "connection to tuner was lost" message when I try to watch in Channels. What stream format do you use in the custom channel settings panel? Would you mind sharing your m3u?

Stream fomat is HLS. And sure, here is my (slighly edited for privacy) m3u:

#EXTINF:-1 channel-id="Front Gate" channel-number="10000” tvg-logo="" tvg-name="Front Gate" tvc-guide-title="Front Gate" tvc-guide-description="Main Street", tvc-guide-art="", Front Gate

I wonder what else might be different from my setup, and yours? I have Scrypted running via docker, on a Pi otherwise running Homebridge. But it is a 32-bit system. So I am considering moving it over to another Pi, that is running Home Assistant, and using the Scrypted add-on, because that system is 64-bit. I have a few other things to tinker with before that, though...

Although I have no clue what I did to change it but I have it working now. At least on every ring camera except one where I'm getting the same error. It's getting late so I'll look at it tomorrow with fresh eyes.

I was using HLS. To answer your question I have scrypted running in docker on a Synology NAS along with ChannelsDVR and homekit.

Thanks for your help.

I'm trying to get this to work with my ring cameras. I have scrypted up and running but I can't seem to get it to output an m3u url that channels likes. Any assistance or tips would be appreciated for folks that do have this working.

Scrypted outputs an RTSP stream you can use, not an M3U. You use that to make an M3U for Channels DVR yourself. Here's mine: Scrypted gets Ring doorbell and security camera feeds into Channels' guide too - #9 by Fofer