Setting up a new server on a Raspberry Pi fails

I've tried on two new Pi's, so it's not a hardware issue.

Per the instructions, I flashed the Pi EEPROM for USB boot using the official Pi imager. I loaded the Channels custom OS image using the same Pi imager on a brand-new Toshiba 2gb USB3 HDD (three times just to make sure and it verified correctly all three times). And yes, the SD card I used to flash the EEPROM was removed.

The red and green lights start up solid, but the green light goes out after a few seconds (it's supposed to stay on solid green). The light on the HDD goes on and I hear it spinning at first. Then it goes off. It's plugged into my router directly, but I can't reach it via http://dvr-server.

UPDATE: I tried using a USB C hub with my laptop charger attached. The drive is attached to the hub, not directly to the Pi. The green light now goes on solid. I thought the USB C on the Pi was for power only. However still not able to reach the server via http://dvr-server.

Anyone have any idea why this is not working?

IIRC, there are known issues trying to use USB-C for both power and a drive.

Plugging into a regular USB port should work. Can you try the black (USB2) ports instead of the blue (USG3). Some drive enclosures are known to be buggy in USB3 mode. (Although if this is an off-the-shelf toshiba portable then it should work...)

I assume you don't have a microHDMI and thus can't check the hdmi console?

What I've found is that an off the shelf Toshiba 2TB USB3 HDD does not seem to work when connected to either the USB2 or USB3 ports. Green light does not light solid. When I connect it to a USB3 hub and connect the hub to my laptop charger and the Pi - the green light goes solid. So, power seems to be an issue. I guess I should investigate a powered hub just for the drive, not to power the Pi.

I did have access to a micro HDMI adapter (I returned it). Here is what I found:

2 USB devices found
Scanning for storage devices
0 devices found
Card did not respond to voltage select
device 0: unknown device
waiting for PHY auto negotiation to complete -110
PHY startup failed
Missing environmental variable: bootfile

I'm not a programmer, but I think that the device is found but it does not respond correctly, and the Pi does not boot.

Yea sounds like a power issue.

Any idea how much power a HDD would require? I found a hub with a 5V 2.5 amp power supply. I guess if it's dedicated to the drive, it should be OK. Thoughts?

Yea if you power the disk separately then the Pi itself won't run out of current and will work more reliably.

I struggled with this issue for two days and with two Raspberry Pi's. Turns out the power from the USB3 connection was not enough to properly power the USB3 HDD. I bought a cheap powered USB3 hub, connected it between the drive and the Pi and everything works perfectly. Hope you find this post if you are having the same issue!

4 Likes